# CVE-2018-1000077: RubyGems Improper Input Validation vulnerability

> RubyGems allows malicious gems to set invalid homepage URLs due to improper input validation, potentially misleading users or tools.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-1000077, GHSA-gv86-43rv-79m2, UBUNTU-CVE-2018-1000077

## What is CVE-2018-1000077?

CVE-2018-1000077 is a medium-severity vulnerability in Debian Debian Linux, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Improper Input Validation vulnerability in ruby gems specification homepage attribute that can result in a malicious gem could set an invalid homepage URL. This vulnerability appears to have been fixed in 2.7.6.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-1000077?

4 open source packages ship an affected version, including org.jruby:jruby-stdlib and rubygems-update. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jruby:jruby-stdlib` | Maven | All versions | 9.1.16.0 |
| `org.jruby:jruby-stdlib` | Maven | All versions | 9.1.16.0 |
| `rubygems-update` | RubyGems | All versions | 2.7.6 |
| `rubygems-update` | RubyGems | All versions | 2.7.6 |

Products: Debian Debian Linux, Rubygems Rubygems.

## How do I fix CVE-2018-1000077?

Upgrade org.jruby:jruby-stdlib to 9.1.16.0 or later.

## Is CVE-2018-1000077 being exploited?

There is no known exploitation of CVE-2018-1000077 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000077 and fix it if it is affected.

What it is: CVE-2018-1000077 is a medium-severity vulnerability in Debian Debian Linux, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000077 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jruby:jruby-stdlib (Maven): affected all versions; fixed in 9.1.16.0
- org.jruby:jruby-stdlib (Maven): affected all versions; fixed in 9.1.16.0
- rubygems-update (RubyGems): affected all versions; fixed in 2.7.6
- rubygems-update (RubyGems): affected all versions; fixed in 2.7.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000077/ (Markdown: https://insights.sbomify.com/CVE-2018-1000077/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000077
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000077
- OSV: https://osv.dev/vulnerability/CVE-2018-1000077

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000077/
Summaries are generated and may contain mistakes; the official description above is the record.
