CVE-2018-1000078 RubyGems Cross-site Scripting vulnerability
An attacker can execute arbitrary scripts in a victim's browser by hosting a malicious gem with a crafted homepage attribute on a vulnerable RubyGems server.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2018-1000078?
CVE-2018-1000078 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Cross Site Scripting (XSS) vulnerability in gem server display of homepage attribute that can result in XSS. This attack appear to be exploitable via the victim must browse to a malicious gem on a vulnerable gem server. This vulnerability appears to have been fixed in 2.7.6.
Weakness: CWE-79
Which versions are affected by CVE-2018-1000078?
4 open source packages ship an affected version, including org.jruby:jruby-stdlib and rubygems-update. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.jruby:jruby-stdlib Maven | All versions | 9.1.16.0 |
org.jruby:jruby-stdlib Maven | All versions | 9.1.16.0 |
rubygems-update RubyGems | All versions | 2.7.6 |
rubygems-update RubyGems | All versions | 2.7.6 |
Products include Debian Debian Linux, Rubygems Rubygems.
How do I fix CVE-2018-1000078?
Upgrade org.jruby:jruby-stdlib to 9.1.16.0 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2018-1000078 being exploited?
There is no known exploitation of CVE-2018-1000078 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2018-1000078, GHSA-87qx-g5wg-mwmj, UBUNTU-CVE-2018-1000078.