CVE-2018-1000086 pym.js CSRF Vulnerability
Cross-site request forgery in Pym.js allows attackers to execute arbitrary JavaScript on pages using the library when users visit malicious sites.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2018-1000086?
CVE-2018-1000086 is a high-severity vulnerability in n/a, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
NPR Visuals Team Pym.js version versions 0.4.2 up to 1.3.1 contains a Cross ite Request Forgery (CSRF) vulnerability in Pym.js _onNavigateToMessage function. https://github.com/nprapps/pym.js/blob/master/src/pym.js#L573 that can result in Arbitrary javascript code execution. This attack appear to be exploitable via Attacker gains full javascript access to pages with Pym.js embeds when user visits an attacker crafted page.. This vulnerability appears to have been fixed in versions 1.3.2 and later.
Weakness: CWE-352
Which versions are affected by CVE-2018-1000086?
3 open source packages ship an affected version, including pym.js and widgetframe. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
pym.js npm | From 0.4.2 | 1.3.2 |
pym.js npm | From 0.4.2 | 1.3.2 |
widgetframe CRAN | From 0.1.0 | None |
Products include Npr Pym.js.
How do I fix CVE-2018-1000086?
Upgrade pym.js to 1.3.2 or later.
Is CVE-2018-1000086 being exploited?
There is no known exploitation of CVE-2018-1000086 in the wild and no public exploit code.
Sources
Also known as GHSA-82gw-pqf7-q3j2, RSEC-2026-0.