{"answers":{"affected":"3 open source packages ship an affected version, including pym.js and widgetframe. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000086 in the wild and no public exploit code.","fix":"Upgrade pym.js to 1.3.2 or later.","what":"CVE-2018-1000086 is a high-severity vulnerability in n/a, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-1000086 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000086 is a high-severity vulnerability in n/a, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-1000086 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pym.js (npm): affected from 0.4.2; fixed in 1.3.2\n- pym.js (npm): affected from 0.4.2; fixed in 1.3.2\n- widgetframe (CRAN): affected from 0.1.0; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000086/ (Markdown: https://insights.sbomify.com/CVE-2018-1000086/index.md)","id":"CVE-2018-1000086","markdown":"https://insights.sbomify.com/CVE-2018-1000086/index.md","name":"CVE-2018-1000086","record":{"aliases":["GHSA-82gw-pqf7-q3j2","RSEC-2026-0"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript embedding library","requires_auth":"none","summary":"Cross-site request forgery in Pym.js allows attackers to execute arbitrary JavaScript on pages using the library when users visit malicious sites.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pym.js","vendor":"npr"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"NPR Visuals Team Pym.js version versions 0.4.2 up to 1.3.1 contains a Cross ite Request Forgery (CSRF) vulnerability in Pym.js _onNavigateToMessage function. https://github.com/nprapps/pym.js/blob/master/src/pym.js#L573 that can result in Arbitrary javascript code execution. This attack appear to be exploitable via Attacker gains full javascript access to pages with Pym.js embeds when user visits an attacker crafted page.. This vulnerability appears to have been fixed in versions 1.3.2 and later.","ecosystems":["CRAN","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"pym.js CSRF Vulnerability","id":"CVE-2018-1000086","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"csrf","year":"2018"},"n_packages":3,"n_references":3,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-1000087"},"packages":[{"ecosystem":"CRAN","fixed":[],"introduced":["0.1.0"],"last_affected":[],"package":"widgetframe","purl":"pkg:cran/widgetframe","source":"RSEC-2026-0"},{"ecosystem":"npm","fixed":["1.3.2"],"introduced":["0.4.2"],"last_affected":[],"package":"pym.js","purl":null,"source":"GHSA-82gw-pqf7-q3j2"},{"ecosystem":"npm","fixed":["1.3.2"],"introduced":["0.4.2"],"last_affected":[],"package":"pym.js","purl":"pkg:npm/pym.js","source":"GHSA-82gw-pqf7-q3j2"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2018-1000085"},"products":["n/a"],"published":"2018-03-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"Apache-2.0","name":"R Consortium","prefix":"RSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Cross-site request forgery in Pym.js allows attackers to execute arbitrary JavaScript on pages using the library when users visit malicious sites.","url":"https://insights.sbomify.com/CVE-2018-1000086/"}