# CVE-2018-1000086: pym.js CSRF Vulnerability

> Cross-site request forgery in Pym.js allows attackers to execute arbitrary JavaScript on pages using the library when users visit malicious sites.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-82gw-pqf7-q3j2, RSEC-2026-0

## What is CVE-2018-1000086?

CVE-2018-1000086 is a high-severity vulnerability in n/a, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

NPR Visuals Team Pym.js version versions 0.4.2 up to 1.3.1 contains a Cross ite Request Forgery (CSRF) vulnerability in Pym.js _onNavigateToMessage function. https://github.com/nprapps/pym.js/blob/master/src/pym.js#L573 that can result in Arbitrary javascript code execution. This attack appear to be exploitable via Attacker gains full javascript access to pages with Pym.js embeds when user visits an attacker crafted page.. This vulnerability appears to have been fixed in versions 1.3.2 and later.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2018-1000086?

3 open source packages ship an affected version, including pym.js and widgetframe. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pym.js` | npm | From 0.4.2 | 1.3.2 |
| `pym.js` | npm | From 0.4.2 | 1.3.2 |
| `widgetframe` | CRAN | From 0.1.0 | None |

Products: Npr Pym.js.

## How do I fix CVE-2018-1000086?

Upgrade pym.js to 1.3.2 or later.

## Is CVE-2018-1000086 being exploited?

There is no known exploitation of CVE-2018-1000086 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000086 and fix it if it is affected.

What it is: CVE-2018-1000086 is a high-severity vulnerability in n/a, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-1000086 in the wild and no public exploit code.

Affected packages and fixed versions:
- pym.js (npm): affected from 0.4.2; fixed in 1.3.2
- pym.js (npm): affected from 0.4.2; fixed in 1.3.2
- widgetframe (CRAN): affected from 0.1.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000086/ (Markdown: https://insights.sbomify.com/CVE-2018-1000086/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000086
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000086
- OSV: https://osv.dev/vulnerability/CVE-2018-1000086

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000086/
Summaries are generated and may contain mistakes; the official description above is the record.
