{"answers":{"affected":"2 open source packages ship an affected version, including doorkeeper. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000088 in the wild and no public exploit code.","fix":"Upgrade doorkeeper to 4.2.6 or later.","what":"CVE-2018-1000088 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-1000088 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000088 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-1000088 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- doorkeeper (RubyGems): affected from 2.1.0; fixed in 4.2.6\n- doorkeeper (RubyGems): affected from 2.1.0; fixed in 4.2.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000088/ (Markdown: https://insights.sbomify.com/CVE-2018-1000088/index.md)","id":"CVE-2018-1000088","markdown":"https://insights.sbomify.com/CVE-2018-1000088/index.md","name":"CVE-2018-1000088","record":{"aliases":["DEBIAN-CVE-2018-1000088","GHSA-hwhh-2fwm-cfgw","UBUNTU-CVE-2018-1000088"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby OAuth library","requires_auth":"none","summary":"Stored XSS in Doorkeeper OAuth app form allows attackers to execute arbitrary scripts in victim browsers via malicious client names.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"doorkeeper","vendor":"doorkeeper_project"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Doorkeeper version 2.1.0 through 4.2.5 contains a Cross Site Scripting (XSS) vulnerability in web view's OAuth app form, user authorization prompt web view that can result in Stored XSS on the OAuth Client's name will cause users interacting with it will execute payload. This attack appear to be exploitable via The victim must be tricked to click an opaque link to the web view that runs the XSS payload. A malicious version virtually indistinguishable from a normal link.. This vulnerability appears to have been fixed in 4.2.6, 4.3.0.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Doorkeeper is vulnerable to stored XSS and code execution","id":"CVE-2018-1000088","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2018"},"n_packages":2,"n_references":4,"next":{"headline":"django-anymail Includes Sensitive Information in Log Files","id":"CVE-2018-1000089"},"packages":[{"ecosystem":"RubyGems","fixed":["4.2.6"],"introduced":["2.1.0"],"last_affected":[],"package":"doorkeeper","purl":null,"source":"GHSA-hwhh-2fwm-cfgw"},{"ecosystem":"RubyGems","fixed":["4.2.6"],"introduced":["2.1.0"],"last_affected":[],"package":"doorkeeper","purl":"pkg:gem/doorkeeper","source":"GHSA-hwhh-2fwm-cfgw"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-1000087"},"products":["n/a"],"published":"2018-03-13","related":[{"cvss_score":9.1,"headline":"Doorkeeper is vulnerable to replay attacks","id":"CVE-2016-6582","kev_date_added":null,"published":"2017-01-23"},{"cvss_score":7.5,"headline":"Exposure of Sensitive Information to an Unauthorized Actor in Doorkeeper","id":"CVE-2020-10187","kev_date_added":null,"published":"2020-05-04"},{"cvss_score":7.5,"headline":"Doorkeeper subject to Incorrect Permission Assignment","id":"CVE-2018-1000211","kev_date_added":null,"published":"2018-07-13"},{"cvss_score":6.8,"headline":"Doorkeeper vulnerable to Cross-site Request Forgery","id":"CVE-2014-8144","kev_date_added":null,"published":"2014-12-31"},{"cvss_score":4.2,"headline":"Doorkeeper Improper Authentication vulnerability","id":"CVE-2023-34246","kev_date_added":null,"published":"2023-06-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Stored XSS in Doorkeeper OAuth app form allows attackers to execute arbitrary scripts in victim browsers via malicious client names.","url":"https://insights.sbomify.com/CVE-2018-1000088/"}