# CVE-2018-1000088: Doorkeeper is vulnerable to stored XSS and code execution

> Stored XSS in Doorkeeper OAuth app form allows attackers to execute arbitrary scripts in victim browsers via malicious client names.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-1000088, GHSA-hwhh-2fwm-cfgw, UBUNTU-CVE-2018-1000088

## What is CVE-2018-1000088?

CVE-2018-1000088 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Doorkeeper version 2.1.0 through 4.2.5 contains a Cross Site Scripting (XSS) vulnerability in web view's OAuth app form, user authorization prompt web view that can result in Stored XSS on the OAuth Client's name will cause users interacting with it will execute payload. This attack appear to be exploitable via The victim must be tricked to click an opaque link to the web view that runs the XSS payload. A malicious version virtually indistinguishable from a normal link.. This vulnerability appears to have been fixed in 4.2.6, 4.3.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-1000088?

2 open source packages ship an affected version, including doorkeeper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `doorkeeper` | RubyGems | From 2.1.0 | 4.2.6 |
| `doorkeeper` | RubyGems | From 2.1.0 | 4.2.6 |

Products: Doorkeeper Project Doorkeeper.

## How do I fix CVE-2018-1000088?

Upgrade doorkeeper to 4.2.6 or later.

## Is CVE-2018-1000088 being exploited?

There is no known exploitation of CVE-2018-1000088 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2016-6582](https://insights.sbomify.com/CVE-2016-6582/): Doorkeeper is vulnerable to replay attacks (critical 9.1)
- [CVE-2020-10187](https://insights.sbomify.com/CVE-2020-10187/): Exposure of Sensitive Information to an Unauthorized Actor in Doorkeeper (high 7.5)
- [CVE-2018-1000211](https://insights.sbomify.com/CVE-2018-1000211/): Doorkeeper subject to Incorrect Permission Assignment (high 7.5)
- [CVE-2014-8144](https://insights.sbomify.com/CVE-2014-8144/): Doorkeeper vulnerable to Cross-site Request Forgery (medium 6.8)
- [CVE-2023-34246](https://insights.sbomify.com/CVE-2023-34246/): Doorkeeper Improper Authentication vulnerability (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000088 and fix it if it is affected.

What it is: CVE-2018-1000088 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-1000088 in the wild and no public exploit code.

Affected packages and fixed versions:
- doorkeeper (RubyGems): affected from 2.1.0; fixed in 4.2.6
- doorkeeper (RubyGems): affected from 2.1.0; fixed in 4.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000088/ (Markdown: https://insights.sbomify.com/CVE-2018-1000088/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000088
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000088
- OSV: https://osv.dev/vulnerability/CVE-2018-1000088

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000088/
Summaries are generated and may contain mistakes; the official description above is the record.
