# CVE-2018-1000089: django-anymail Includes Sensitive Information in Log Files

> Attackers with access to error logs can discover webhook secrets to fabricate email tracking events in Django applications using Anymail.

- **Severity:** High 7.4 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-1000089, GHSA-qh9x-mc42-vg4g, PYSEC-2018-46

## What is CVE-2018-1000089?

CVE-2018-1000089 is a high-severity vulnerability in n/a, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Anymail django-anymail version version 0.2 through 1.3 contains a CWE-532, CWE-209 vulnerability in WEBHOOK_AUTHORIZATION setting value that can result in An attacker with access to error logs could fabricate email tracking events. This attack appear to be exploitable via If you have exposed your Django error reports, an attacker could discover your ANYMAIL_WEBHOOK setting and use this to post fabricated or malicious Anymail tracking/inbound events to your app. This vulnerability appears to have been fixed in v1.4.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2018-1000089?

3 open source packages ship an affected version, including django-anymail. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django-anymail` | PyPI | From 0.2 | 1.4 |
| `django-anymail` | PyPI | From 0.2 | 1.4 |
| `django-anymail` | PyPI | From 0.2 | 1.4 |

Products: Django-Anymail Project Django-Anymail.

## How do I fix CVE-2018-1000089?

Upgrade django-anymail to 1.4 or later.

## Is CVE-2018-1000089 being exploited?

There is no known exploitation of CVE-2018-1000089 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000089 and fix it if it is affected.

What it is: CVE-2018-1000089 is a high-severity vulnerability in n/a, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000089 in the wild and no public exploit code.

Affected packages and fixed versions:
- django-anymail (PyPI): affected from 0.2; fixed in 1.4
- django-anymail (PyPI): affected from 0.2; fixed in 1.4
- django-anymail (PyPI): affected from 0.2; fixed in 1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000089/ (Markdown: https://insights.sbomify.com/CVE-2018-1000089/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000089
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000089
- OSV: https://osv.dev/vulnerability/CVE-2018-1000089

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000089/
Summaries are generated and may contain mistakes; the official description above is the record.
