CVE-2018-1000098 Integer overflow in n/a

High 7.5 Published Updated

An integer overflow in PJSIP SDP parsing allows remote attackers to cause a denial of service via crafted messages.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1000098?

CVE-2018-1000098 is a high-severity vulnerability in Debian Debian Linux, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Teluu PJSIP version 2.7.1 and earlier contains a Integer Overflow vulnerability in pjmedia SDP parsing that can result in Crash. This attack appear to be exploitable via Sending a specially crafted message. This vulnerability appears to have been fixed in 2.7.2.

Weakness: CWE-190

Which versions are affected by CVE-2018-1000098?

It affects 2 products.

Products include Debian Debian Linux, Teluu Pjsip.

How do I fix CVE-2018-1000098?

Upgrade to a fixed version.

Is CVE-2018-1000098 being exploited?

There is no known exploitation of CVE-2018-1000098 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as GHSA-chm5-gp28-v8xw, UBUNTU-CVE-2018-1000098.

Is CVE-2018-1000098 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free