CVE-2018-1000099 Null dereference in n/a

High 7.5 Published Updated

A remote attacker can cause a denial of service by sending a specially crafted SDP message to applications using the PJSIP library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1000099?

CVE-2018-1000099 is a high-severity vulnerability in Debian Debian Linux, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Teluu PJSIP version 2.7.1 and earlier contains a Access of Null/Uninitialized Pointer vulnerability in pjmedia SDP parsing that can result in Crash. This attack appear to be exploitable via Sending a specially crafted message. This vulnerability appears to have been fixed in 2.7.2.

Weakness: CWE-824

Which versions are affected by CVE-2018-1000099?

It affects 2 products.

Products include Debian Debian Linux, Teluu Pjsip.

How do I fix CVE-2018-1000099?

Upgrade to a fixed version.

Is CVE-2018-1000099 being exploited?

There is no known exploitation of CVE-2018-1000099 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as GHSA-g2mm-3mxm-q4ww, UBUNTU-CVE-2018-1000099.

Is CVE-2018-1000099 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free