{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:coverity. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000104 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:coverity to 1.11.0 or later.","what":"CVE-2018-1000104 is a high-severity vulnerability in n/a, published on 13 Mar 2018. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000104 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000104 is a high-severity vulnerability in n/a, published on 13 Mar 2018. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000104 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:coverity (Maven): affected all versions; fixed in 1.11.0\n- org.jenkins-ci.plugins:coverity (Maven): affected all versions; fixed in 1.11.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000104/ (Markdown: https://insights.sbomify.com/CVE-2018-1000104/index.md)","id":"CVE-2018-1000104","markdown":"https://insights.sbomify.com/CVE-2018-1000104/index.md","name":"CVE-2018-1000104","record":{"aliases":["GHSA-cghg-jcv6-4v5m"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Jenkins Coverity Plugin","requires_auth":"low_privilege","summary":"An attacker with local access or browser control can retrieve stored keystore and private key passwords from the Jenkins Coverity Plugin.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"coverity","vendor":"jenkins"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-522","name":"Insufficiently Protected Credentials"}],"description":"A plaintext storage of a password vulnerability exists in Jenkins Coverity Plugin 1.10.0 and earlier in CIMInstance.java that allows an attacker with local file system access or control of a Jenkins administrator's web browser (e.g. malicious extension) to retrieve the configured keystore and private key passwords.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Coverity Plugin has Insufficiently Protected Credentials","id":"CVE-2018-1000104","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Incorrect Authorization in Jenkins Gerrit Trigger Plugin","id":"CVE-2018-1000105"},"packages":[{"ecosystem":"Maven","fixed":["1.11.0"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:coverity","purl":null,"source":"GHSA-cghg-jcv6-4v5m"},{"ecosystem":"Maven","fixed":["1.11.0"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:coverity","purl":"pkg:maven/org.jenkins-ci.plugins/coverity","source":"GHSA-cghg-jcv6-4v5m"}],"prev":{"headline":"Null dereference in n/a","id":"CVE-2018-1000101"},"products":["n/a"],"published":"2018-03-13","related":[{"cvss_score":8.8,"headline":"Jenkins Coverity Plugin vulnerable to cross-site request forgery (CSRF)","id":"CVE-2022-36920","kev_date_added":null,"published":"2022-07-27"},{"cvss_score":8.1,"headline":"Missing permission check in Coverity Plugin allows capturing credentials","id":"CVE-2022-36921","kev_date_added":null,"published":"2022-07-27"},{"cvss_score":4.3,"headline":"Jenkins Coverity Plugin allows attackers with Overall/Read permission to enumerate credentials IDs","id":"CVE-2022-36919","kev_date_added":null,"published":"2022-07-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"An attacker with local access or browser control can retrieve stored keystore and private key passwords from the Jenkins Coverity Plugin.","url":"https://insights.sbomify.com/CVE-2018-1000104/"}