# CVE-2018-1000104: Jenkins Coverity Plugin has Insufficiently Protected Credentials

> An attacker with local access or browser control can retrieve stored keystore and private key passwords from the Jenkins Coverity Plugin.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Mar 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-cghg-jcv6-4v5m

## What is CVE-2018-1000104?

CVE-2018-1000104 is a high-severity vulnerability in n/a, published on 13 Mar 2018. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A plaintext storage of a password vulnerability exists in Jenkins Coverity Plugin 1.10.0 and earlier in CIMInstance.java that allows an attacker with local file system access or control of a Jenkins administrator's web browser (e.g. malicious extension) to retrieve the configured keystore and private key passwords.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2018-1000104?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:coverity. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:coverity` | Maven | All versions | 1.11.0 |
| `org.jenkins-ci.plugins:coverity` | Maven | All versions | 1.11.0 |

Products: Jenkins Coverity.

## How do I fix CVE-2018-1000104?

Upgrade org.jenkins-ci.plugins:coverity to 1.11.0 or later.

## Is CVE-2018-1000104 being exploited?

There is no known exploitation of CVE-2018-1000104 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-36920](https://insights.sbomify.com/CVE-2022-36920/): Jenkins Coverity Plugin vulnerable to cross-site request forgery (CSRF) (high 8.8)
- [CVE-2022-36921](https://insights.sbomify.com/CVE-2022-36921/): Missing permission check in Coverity Plugin allows capturing credentials (high 8.1)
- [CVE-2022-36919](https://insights.sbomify.com/CVE-2022-36919/): Jenkins Coverity Plugin allows attackers with Overall/Read permission to enumerate credentials IDs (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000104 and fix it if it is affected.

What it is: CVE-2018-1000104 is a high-severity vulnerability in n/a, published on 13 Mar 2018. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000104 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:coverity (Maven): affected all versions; fixed in 1.11.0
- org.jenkins-ci.plugins:coverity (Maven): affected all versions; fixed in 1.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000104/ (Markdown: https://insights.sbomify.com/CVE-2018-1000104/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000104
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000104
- OSV: https://osv.dev/vulnerability/CVE-2018-1000104

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000104/
Summaries are generated and may contain mistakes; the official description above is the record.
