{"answers":{"affected":"2 open source packages ship an affected version, including com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000106 in the wild and no public exploit code.","fix":"Upgrade com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger to 2.27.5 or later.","what":"CVE-2018-1000106 is a medium-severity missing authorization vulnerability in n/a, published on 13 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000106 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000106 is a medium-severity missing authorization vulnerability in n/a, published on 13 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000106 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven): affected all versions; fixed in 2.27.5\n- com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven): affected all versions; fixed in 2.27.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000106/ (Markdown: https://insights.sbomify.com/CVE-2018-1000106/index.md)","id":"CVE-2018-1000106","markdown":"https://insights.sbomify.com/CVE-2018-1000106/index.md","name":"CVE-2018-1000106","record":{"aliases":["GHSA-4vf2-cm23-rf4c"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Gerrit Plugin","requires_auth":"low_privilege","summary":"Attackers with read access can modify Gerrit configuration due to missing authorization checks in the Jenkins Gerrit Trigger Plugin.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"gerrit_trigger","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L","version":"3.0"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"An improper authorization vulnerability exists in Jenkins Gerrit Trigger Plugin 2.27.4 and earlier in GerritManagement.java, GerritServer.java, and PluginImpl.java that allows an attacker with Overall/Read access to modify the Gerrit configuration in Jenkins.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Incorrect Authorization in Jenkins Gerrit Trigger Plugin","id":"CVE-2018-1000106","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Improper authorization in Jenkins Job and Node Ownership Plugin","id":"CVE-2018-1000107"},"packages":[{"ecosystem":"Maven","fixed":["2.27.5"],"introduced":["0"],"last_affected":[],"package":"com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger","purl":null,"source":"GHSA-4vf2-cm23-rf4c"},{"ecosystem":"Maven","fixed":["2.27.5"],"introduced":["0"],"last_affected":[],"package":"com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger","purl":"pkg:maven/com.sonyericsson.hudson.plugins.gerrit/gerrit-trigger","source":"GHSA-4vf2-cm23-rf4c"}],"prev":{"headline":"Incorrect Authorization in Jenkins Gerrit Trigger Plugin","id":"CVE-2018-1000105"},"products":["n/a"],"published":"2018-03-13","related":[{"cvss_score":8.8,"headline":"Cross-Site Request Forgery in Jenkins Gerrit Trigger Plugin","id":"CVE-2019-16551","kev_date_added":null,"published":"2019-12-17"},{"cvss_score":6.5,"headline":"Cross-site request forgery in Jenkins Gerrit Trigger Plugin","id":"CVE-2023-24423","kev_date_added":null,"published":"2023-01-24"},{"cvss_score":5.4,"headline":"Stored Cross-site Scripting vulnerability in Jenkins Gerrit Trigger Plugin","id":"CVE-2022-29039","kev_date_added":null,"published":"2022-04-12"},{"cvss_score":5.4,"headline":"Missing permission check in Jenkins Gerrit Trigger Plugin","id":"CVE-2019-16552","kev_date_added":null,"published":"2019-12-17"},{"cvss_score":4.3,"headline":"Incorrect Authorization in Jenkins Gerrit Trigger Plugin","id":"CVE-2018-1000105","kev_date_added":null,"published":"2018-03-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers with read access can modify Gerrit configuration due to missing authorization checks in the Jenkins Gerrit Trigger Plugin.","url":"https://insights.sbomify.com/CVE-2018-1000106/"}