# CVE-2018-1000107: Improper authorization in Jenkins Job and Node Ownership Plugin

> Attackers with configure permissions can override ownership metadata in Jenkins due to missing authorization checks in the Ownership Plugin.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Mar 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-72x3-c7jc-q35x

## What is CVE-2018-1000107?

CVE-2018-1000107 is a medium-severity missing authorization vulnerability in n/a, published on 13 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An improper authorization vulnerability exists in Jenkins Job and Node Ownership Plugin 0.11.0 and earlier in OwnershipDescription.java, JobOwnerJobProperty.java, and OwnerNodeProperty.java that allow an attacker with Job/Configure or Computer/Configure permission and without Ownership related permissions to override ownership metadata.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2018-1000107?

2 open source packages ship an affected version, including com.synopsys.jenkinsci:ownership. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.synopsys.jenkinsci:ownership` | Maven | All versions | 0.12.0 |
| `com.synopsys.jenkinsci:ownership` | Maven | All versions | 0.12.0 |

Products: Jenkins Job and Node Ownership.

## How do I fix CVE-2018-1000107?

Upgrade com.synopsys.jenkinsci:ownership to 0.12.0 or later.

## Is CVE-2018-1000107 being exploited?

There is no known exploitation of CVE-2018-1000107 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-28150](https://insights.sbomify.com/CVE-2022-28150/): Cross site request forgery in Jenkins Job and Node ownership Plugin (high 8.8)
- [CVE-2022-28149](https://insights.sbomify.com/CVE-2022-28149/): Stored Cross-site Scripting vulnerability in Jenkins Job and Node ownership Plugin (medium 5.4)
- [CVE-2022-28151](https://insights.sbomify.com/CVE-2022-28151/): Missing permission check in Jenkins Job and Node ownership Plugin (medium 4.3)
- [CVE-2022-28152](https://insights.sbomify.com/CVE-2022-28152/): CSRF vulnerability in Jenkins Job and Node ownership Plugin (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000107 and fix it if it is affected.

What it is: CVE-2018-1000107 is a medium-severity missing authorization vulnerability in n/a, published on 13 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000107 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.synopsys.jenkinsci:ownership (Maven): affected all versions; fixed in 0.12.0
- com.synopsys.jenkinsci:ownership (Maven): affected all versions; fixed in 0.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000107/ (Markdown: https://insights.sbomify.com/CVE-2018-1000107/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000107
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000107
- OSV: https://osv.dev/vulnerability/CVE-2018-1000107

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000107/
Summaries are generated and may contain mistakes; the official description above is the record.
