# CVE-2018-1000109: Jenkins Google Play Android Publisher Plugin allows attacker to obtain credential IDs

> An attacker can obtain credential IDs due to improper authorization in the Jenkins Google Play Android Publisher Plugin.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Mar 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-rvx4-gg8w-qw24

## What is CVE-2018-1000109?

CVE-2018-1000109 is a medium-severity missing authorization vulnerability in n/a, published on 13 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An improper authorization vulnerability exists in Jenkins Google Play Android Publisher Plugin version 1.6 and earlier in GooglePlayBuildStepDescriptor.java that allow an attacker to obtain credential IDs.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2018-1000109?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:google-play-android-publisher. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:google-play-android-publisher` | Maven | All versions | 1.7 |
| `org.jenkins-ci.plugins:google-play-android-publisher` | Maven | All versions | 1.7 |

Products: Jenkins Google-Play-Android-Publisher.

## How do I fix CVE-2018-1000109?

Upgrade org.jenkins-ci.plugins:google-play-android-publisher to 1.7 or later.

## Is CVE-2018-1000109 being exploited?

There is no known exploitation of CVE-2018-1000109 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000109 and fix it if it is affected.

What it is: CVE-2018-1000109 is a medium-severity missing authorization vulnerability in n/a, published on 13 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000109 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:google-play-android-publisher (Maven): affected all versions; fixed in 1.7
- org.jenkins-ci.plugins:google-play-android-publisher (Maven): affected all versions; fixed in 1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000109/ (Markdown: https://insights.sbomify.com/CVE-2018-1000109/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000109
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000109
- OSV: https://osv.dev/vulnerability/CVE-2018-1000109

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000109/
Summaries are generated and may contain mistakes; the official description above is the record.
