{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:git. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000110 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:git to 3.8.0 or later.","what":"CVE-2018-1000110 is a medium-severity missing authorization vulnerability in n/a, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000110 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000110 is a medium-severity missing authorization vulnerability in n/a, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000110 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:git (Maven): affected all versions; fixed in 3.8.0\n- org.jenkins-ci.plugins:git (Maven): affected all versions; fixed in 3.8.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000110/ (Markdown: https://insights.sbomify.com/CVE-2018-1000110/index.md)","id":"CVE-2018-1000110","markdown":"https://insights.sbomify.com/CVE-2018-1000110/index.md","name":"CVE-2018-1000110","record":{"aliases":["GHSA-46p2-fwqg-3h6m"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Git Plugin","requires_auth":"none","summary":"An attacker with network access can obtain a list of nodes and users due to improper authorization in the Jenkins Git Plugin.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"git","vendor":"jenkins"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"An improper authorization vulnerability exists in Jenkins Git Plugin version 3.7.0 and earlier in GitStatus.java that allows an attacker with network access to obtain a list of nodes and users.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Incorrect Authorization in Jenkins Git Plugin","id":"CVE-2018-1000110","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins Subversion Plugin Incorrect Authorization vulnerability","id":"CVE-2018-1000111"},"packages":[{"ecosystem":"Maven","fixed":["3.8.0"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:git","purl":null,"source":"GHSA-46p2-fwqg-3h6m"},{"ecosystem":"Maven","fixed":["3.8.0"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:git","purl":"pkg:maven/org.jenkins-ci.plugins/git","source":"GHSA-46p2-fwqg-3h6m"}],"prev":{"headline":"Jenkins Google Play Android Publisher Plugin allows attacker to obtain credential IDs","id":"CVE-2018-1000109"},"products":["n/a"],"published":"2018-03-13","related":[{"cvss_score":8.8,"headline":"Lack of authentication mechanism in Jenkins Git Plugin webhook","id":"CVE-2022-36882","kev_date_added":null,"published":"2022-07-27"},{"cvss_score":7.5,"headline":"Lack of authentication mechanism in Jenkins Git Plugin webhook","id":"CVE-2022-36883","kev_date_added":null,"published":"2022-07-27"},{"cvss_score":7.5,"headline":"Path traversal in Jenkins Git Mercurial and Repo Plugins","id":"CVE-2022-30947","kev_date_added":null,"published":"2022-05-17"},{"cvss_score":7.5,"headline":"Cross-Site Request Forgery in Jenkins Git Plugin","id":"CVE-2017-1000092","kev_date_added":null,"published":"2017-10-04"},{"cvss_score":6.5,"headline":"Improper masking of credentials Jenkins in Git Plugin","id":"CVE-2022-38663","kev_date_added":null,"published":"2022-08-23"},{"cvss_score":6.4,"headline":"Server-Side Request Forgery in Jenkins Git Plugin","id":"CVE-2018-1000182","kev_date_added":null,"published":"2018-06-05"},{"cvss_score":6.1,"headline":"Stored XSS vulnerability in Jenkins Git Plugin","id":"CVE-2021-21684","kev_date_added":null,"published":"2021-10-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"An attacker with network access can obtain a list of nodes and users due to improper authorization in the Jenkins Git Plugin.","url":"https://insights.sbomify.com/CVE-2018-1000110/"}