# CVE-2018-1000110: Incorrect Authorization in Jenkins Git Plugin

> An attacker with network access can obtain a list of nodes and users due to improper authorization in the Jenkins Git Plugin.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Mar 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-46p2-fwqg-3h6m

## What is CVE-2018-1000110?

CVE-2018-1000110 is a medium-severity missing authorization vulnerability in n/a, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An improper authorization vulnerability exists in Jenkins Git Plugin version 3.7.0 and earlier in GitStatus.java that allows an attacker with network access to obtain a list of nodes and users.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2018-1000110?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:git. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:git` | Maven | All versions | 3.8.0 |
| `org.jenkins-ci.plugins:git` | Maven | All versions | 3.8.0 |

Products: Jenkins Git.

## How do I fix CVE-2018-1000110?

Upgrade org.jenkins-ci.plugins:git to 3.8.0 or later.

## Is CVE-2018-1000110 being exploited?

There is no known exploitation of CVE-2018-1000110 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-36882](https://insights.sbomify.com/CVE-2022-36882/): Lack of authentication mechanism in Jenkins Git Plugin webhook (high 8.8)
- [CVE-2022-36883](https://insights.sbomify.com/CVE-2022-36883/): Lack of authentication mechanism in Jenkins Git Plugin webhook (high 7.5)
- [CVE-2022-30947](https://insights.sbomify.com/CVE-2022-30947/): Path traversal in Jenkins Git Mercurial and Repo Plugins (high 7.5)
- [CVE-2017-1000092](https://insights.sbomify.com/CVE-2017-1000092/): Cross-Site Request Forgery in Jenkins Git Plugin (high 7.5)
- [CVE-2022-38663](https://insights.sbomify.com/CVE-2022-38663/): Improper masking of credentials Jenkins in Git Plugin (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000110 and fix it if it is affected.

What it is: CVE-2018-1000110 is a medium-severity missing authorization vulnerability in n/a, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000110 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:git (Maven): affected all versions; fixed in 3.8.0
- org.jenkins-ci.plugins:git (Maven): affected all versions; fixed in 3.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000110/ (Markdown: https://insights.sbomify.com/CVE-2018-1000110/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000110
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000110
- OSV: https://osv.dev/vulnerability/CVE-2018-1000110

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000110/
Summaries are generated and may contain mistakes; the official description above is the record.
