{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:subversion. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000111 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:subversion to 2.10.3 or later.","what":"CVE-2018-1000111 is a medium-severity missing authorization vulnerability in n/a, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000111 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000111 is a medium-severity missing authorization vulnerability in n/a, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000111 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:subversion (Maven): affected all versions; fixed in 2.10.3\n- org.jenkins-ci.plugins:subversion (Maven): affected all versions; fixed in 2.10.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000111/ (Markdown: https://insights.sbomify.com/CVE-2018-1000111/index.md)","id":"CVE-2018-1000111","markdown":"https://insights.sbomify.com/CVE-2018-1000111/index.md","name":"CVE-2018-1000111","record":{"aliases":["GHSA-w9gq-8q35-3jcc"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Subversion Plugin","requires_auth":"none","summary":"An attacker with network access can obtain a list of nodes and users due to improper authorization in the Jenkins Subversion Plugin.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"subversion","vendor":"jenkins"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"An improper authorization vulnerability exists in Jenkins Subversion Plugin version 2.10.2 and earlier in SubversionStatus.java and SubversionRepositoryStatus.java that allows an attacker with network access to obtain a list of nodes and users.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Subversion Plugin Incorrect Authorization vulnerability","id":"CVE-2018-1000111","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Incorrect Authorization in Jenkins Mercurial Plugin","id":"CVE-2018-1000112"},"packages":[{"ecosystem":"Maven","fixed":["2.10.3"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:subversion","purl":null,"source":"GHSA-w9gq-8q35-3jcc"},{"ecosystem":"Maven","fixed":["2.10.3"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:subversion","purl":"pkg:maven/org.jenkins-ci.plugins/subversion","source":"GHSA-w9gq-8q35-3jcc"}],"prev":{"headline":"Incorrect Authorization in Jenkins Git Plugin","id":"CVE-2018-1000110"},"products":["n/a"],"published":"2018-03-13","related":[{"cvss_score":7.5,"headline":"Path traversal vulnerability in Jenkins Subversion Plugin allows reading arbitrary files","id":"CVE-2021-21698","kev_date_added":null,"published":"2021-11-04"},{"cvss_score":6.5,"headline":"XXE vulnerability in Jenkins Subversion Plugin","id":"CVE-2020-2304","kev_date_added":null,"published":"2020-11-04"},{"cvss_score":6.5,"headline":"Jenkins Subversion Plugin Cross-Site Request Forgery vulnerability","id":"CVE-2017-1000085","kev_date_added":null,"published":"2017-10-04"},{"cvss_score":5.4,"headline":"Subversion Plugin stored XSS vulnerability","id":"CVE-2020-2111","kev_date_added":null,"published":"2020-02-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"An attacker with network access can obtain a list of nodes and users due to improper authorization in the Jenkins Subversion Plugin.","url":"https://insights.sbomify.com/CVE-2018-1000111/"}