# CVE-2018-1000111: Jenkins Subversion Plugin Incorrect Authorization vulnerability

> An attacker with network access can obtain a list of nodes and users due to improper authorization in the Jenkins Subversion Plugin.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Mar 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-w9gq-8q35-3jcc

## What is CVE-2018-1000111?

CVE-2018-1000111 is a medium-severity missing authorization vulnerability in n/a, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An improper authorization vulnerability exists in Jenkins Subversion Plugin version 2.10.2 and earlier in SubversionStatus.java and SubversionRepositoryStatus.java that allows an attacker with network access to obtain a list of nodes and users.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2018-1000111?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:subversion. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:subversion` | Maven | All versions | 2.10.3 |
| `org.jenkins-ci.plugins:subversion` | Maven | All versions | 2.10.3 |

Products: Jenkins Subversion.

## How do I fix CVE-2018-1000111?

Upgrade org.jenkins-ci.plugins:subversion to 2.10.3 or later.

## Is CVE-2018-1000111 being exploited?

There is no known exploitation of CVE-2018-1000111 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-21698](https://insights.sbomify.com/CVE-2021-21698/): Path traversal vulnerability in Jenkins Subversion Plugin allows reading arbitrary files (high 7.5)
- [CVE-2020-2304](https://insights.sbomify.com/CVE-2020-2304/): XXE vulnerability in Jenkins Subversion Plugin (medium 6.5)
- [CVE-2017-1000085](https://insights.sbomify.com/CVE-2017-1000085/): Jenkins Subversion Plugin Cross-Site Request Forgery vulnerability (medium 6.5)
- [CVE-2020-2111](https://insights.sbomify.com/CVE-2020-2111/): Subversion Plugin stored XSS vulnerability (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000111 and fix it if it is affected.

What it is: CVE-2018-1000111 is a medium-severity missing authorization vulnerability in n/a, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000111 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:subversion (Maven): affected all versions; fixed in 2.10.3
- org.jenkins-ci.plugins:subversion (Maven): affected all versions; fixed in 2.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000111/ (Markdown: https://insights.sbomify.com/CVE-2018-1000111/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000111
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000111
- OSV: https://osv.dev/vulnerability/CVE-2018-1000111

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000111/
Summaries are generated and may contain mistakes; the official description above is the record.
