# CVE-2018-1000113: Stored cross-site scripting vulnerability in Jenkins TestLink Plugin

> An attacker can inject arbitrary HTML and JavaScript into Jenkins via controlled TestLink report names, potentially compromising user sessions.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Mar 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-3rrg-p8xc-3457

## What is CVE-2018-1000113?

CVE-2018-1000113 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Mar 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A cross-site scripting vulnerability exists in Jenkins TestLink Plugin 2.12 and earlier in TestLinkBuildAction/summary.jelly and others that allow an attacker who can control e.g. TestLink report names to have Jenkins serve arbitrary HTML and JavaScript

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-1000113?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:testlink. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:testlink` | Maven | All versions | 2.13 |
| `org.jenkins-ci.plugins:testlink` | Maven | All versions | 2.13 |

Products: Jenkins Testlink.

## How do I fix CVE-2018-1000113?

Upgrade org.jenkins-ci.plugins:testlink to 2.13 or later.

## Is CVE-2018-1000113 being exploited?

There is no known exploitation of CVE-2018-1000113 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-10378](https://insights.sbomify.com/CVE-2019-10378/): Jenkins TestLink Plugin stores credentials in plain text (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000113 and fix it if it is affected.

What it is: CVE-2018-1000113 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Mar 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-1000113 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:testlink (Maven): affected all versions; fixed in 2.13
- org.jenkins-ci.plugins:testlink (Maven): affected all versions; fixed in 2.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000113/ (Markdown: https://insights.sbomify.com/CVE-2018-1000113/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000113
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000113
- OSV: https://osv.dev/vulnerability/CVE-2018-1000113

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000113/
Summaries are generated and may contain mistakes; the official description above is the record.
