CVE-2018-1000127 Integer overflow in n/a

High 7.5 Published Updated

An integer overflow in memcached allows remote attackers to cause data corruption and deadlocks, leading to denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1000127?

CVE-2018-1000127 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

memcached version prior to 1.4.37 contains an Integer Overflow vulnerability in items.c:item_free() that can result in data corruption and deadlocks due to items existing in hash table being reused from free list. This attack appear to be exploitable via network connectivity to the memcached service. This vulnerability appears to have been fixed in 1.4.37 and later.

Weakness: CWE-667, CWE-190

Which versions are affected by CVE-2018-1000127?

It affects 4 products.

Linux distribution packages (2)
memcached Red Hat:openstack:10::el7All versions0:1.4.39-2.el7ost
memcached-debuginfo Red Hat:openstack:10::el7All versions0:1.4.39-2.el7ost

Products include Canonical Ubuntu Linux, Debian Debian Linux, Memcached Memcached, Redhat Openstack.

How do I fix CVE-2018-1000127?

Upgrade to a fixed version.

Is CVE-2018-1000127 being exploited?

There is no known exploitation of CVE-2018-1000127 in the wild and no public exploit code.

All Canonical Ubuntu Linux vulnerabilities

Sources

Also known as DEBIAN-CVE-2018-1000127, DLA-1329-1, GHSA-xfxv-84p3-w8rg, RHSA-2018:2290, UBUNTU-CVE-2018-1000127, USN-3601-1.

Is CVE-2018-1000127 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free