{"answers":{"affected":"It affects 4 products.","exploited":"There is no known exploitation of CVE-2018-1000127 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2018-1000127 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000127 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000127 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000127 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000127/ (Markdown: https://insights.sbomify.com/CVE-2018-1000127/index.md)","id":"CVE-2018-1000127","markdown":"https://insights.sbomify.com/CVE-2018-1000127/index.md","name":"CVE-2018-1000127","record":{"aliases":["DEBIAN-CVE-2018-1000127","DLA-1329-1","GHSA-xfxv-84p3-w8rg","RHSA-2018:2290","UBUNTU-CVE-2018-1000127","USN-3601-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"memcached server","requires_auth":"none","summary":"An integer overflow in memcached allows remote attackers to cause data corruption and deadlocks, leading to denial of service.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"memcached","vendor":"memcached"},{"product":"openstack","vendor":"redhat"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-667","name":"Improper Locking"},{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"memcached version prior to 1.4.37 contains an Integer Overflow vulnerability in items.c:item_free() that can result in data corruption and deadlocks due to items existing in hash table being reused from free list. This attack appear to be exploitable via network connectivity to the memcached service. This vulnerability appears to have been fixed in 1.4.37 and later.","ecosystems":["Red Hat:openstack:10::el7"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Integer overflow in n/a","id":"CVE-2018-1000127","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux","redhat:openstack"],"type":"integer_overflow","year":"2018"},"n_packages":2,"n_references":7,"next":{"headline":"Cross-site Scripting in Jolokia agent","id":"CVE-2018-1000129"},"packages":[{"ecosystem":"Red Hat:openstack:10::el7","fixed":["0:1.4.39-2.el7ost"],"introduced":["0"],"last_affected":[],"package":"memcached","purl":"pkg:rpm/redhat/memcached","source":"RHSA-2018:2290"},{"ecosystem":"Red Hat:openstack:10::el7","fixed":["0:1.4.39-2.el7ost"],"introduced":["0"],"last_affected":[],"package":"memcached-debuginfo","purl":"pkg:rpm/redhat/memcached-debuginfo","source":"RHSA-2018:2290"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2018-1000126"},"products":["n/a"],"published":"2018-03-13","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An integer overflow in memcached allows remote attackers to cause data corruption and deadlocks, leading to denial of service.","url":"https://insights.sbomify.com/CVE-2018-1000127/"}