# CVE-2018-1000129: Cross-site Scripting in Jolokia agent

> An attacker can execute malicious JavaScript in a victim's browser via the Jolokia agent HTTP servlet.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-hfpg-gqjw-779m

## What is CVE-2018-1000129?

CVE-2018-1000129 is a medium-severity cross-site scripting vulnerability in n/a, published on 14 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An XSS vulnerability exists in the Jolokia agent version 1.3.7 in the HTTP servlet that allows an attacker to execute malicious javascript in the victim's browser.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-1000129?

2 open source packages ship an affected version, including org.jolokia:jolokia-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jolokia:jolokia-core` | Maven | From 1.3.7 | 1.5.0 |
| `org.jolokia:jolokia-core` | Maven | From 1.3.7 | 1.5.0 |

Products: Jolokia Jolokia.

## How do I fix CVE-2018-1000129?

Upgrade org.jolokia:jolokia-core to 1.5.0 or later.

## Is CVE-2018-1000129 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-1000129 exists.

Public exploit code:

- https://github.com/shoucheng3/rhuss__jolokia_CVE-2018-1000129_1-4-0 (github_poc): https://github.com/shoucheng3/rhuss__jolokia_CVE-2018-1000129_1-4-0
- Jolokia 1.3.7 - Cross-Site Scripting (nuclei): http/cves/2018/CVE-2018-1000129.yaml

## Other vulnerabilities in n/a

- [CVE-2018-10899](https://insights.sbomify.com/CVE-2018-10899/): Cross-Site Request Forgery in Jolokia (high 8.1)
- [CVE-2014-0168](https://insights.sbomify.com/CVE-2014-0168/): Cross-Site Request Forgery in Jolokia (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000129 and fix it if it is affected.

What it is: CVE-2018-1000129 is a medium-severity cross-site scripting vulnerability in n/a, published on 14 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-1000129 exists.

Affected packages and fixed versions:
- org.jolokia:jolokia-core (Maven): affected from 1.3.7; fixed in 1.5.0
- org.jolokia:jolokia-core (Maven): affected from 1.3.7; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000129/ (Markdown: https://insights.sbomify.com/CVE-2018-1000129/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000129
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000129
- OSV: https://osv.dev/vulnerability/CVE-2018-1000129

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000129/
Summaries are generated and may contain mistakes; the official description above is the record.
