CVE-2018-1000132 Mercurial Incorrect Access Control vulnerability
An attacker with network access can bypass access controls in the Mercurial protocol server to read unauthorized data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-1000132?
CVE-2018-1000132 is a critical missing authorization vulnerability in Debian Debian Linux, published on 14 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Mercurial version 4.5 and earlier contains a Incorrect Access Control (CWE-285) vulnerability in Protocol server that can result in Unauthorized data access. This attack appear to be exploitable via network connectivity. This vulnerability appears to have been fixed in 4.5.1.
Weakness: CWE-732
Which versions are affected by CVE-2018-1000132?
3 open source packages ship an affected version, including mercurial. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mercurial PyPI | All versions | 4.5.1 |
mercurial PyPI | All versions | 4.5.1 |
mercurial PyPI | All versions | 4.5.1 |
Linux distribution packages (1)
mercurial SUSE:Linux Enterprise Software Development Kit 12 SP3 | All versions | 2.8.2-15.10.1 |
Products include Debian Debian Linux, Mercurial Mercurial.
How do I fix CVE-2018-1000132?
Upgrade mercurial to 4.5.1 or later.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2018-1000132 being exploited?
There is no known exploitation of CVE-2018-1000132 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2018-1000132, DEBIAN-CVE-2018-1000132, DLA-1331-1, GHSA-4mr4-7vjv-9hm6, PYSEC-2018-87, SUSE-SU-2018:0933-1 and 1 more.