# CVE-2018-1000132: Mercurial Incorrect Access Control vulnerability

> An attacker with network access can bypass access controls in the Mercurial protocol server to read unauthorized data.

- **Severity:** Critical 9.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** ALPINE-CVE-2018-1000132, DEBIAN-CVE-2018-1000132, DLA-1331-1, GHSA-4mr4-7vjv-9hm6, PYSEC-2018-87, SUSE-SU-2018:0933-1, UBUNTU-CVE-2018-1000132

## What is CVE-2018-1000132?

CVE-2018-1000132 is a critical missing authorization vulnerability in Debian Debian Linux, published on 14 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mercurial version 4.5 and earlier contains a Incorrect Access Control (CWE-285) vulnerability in Protocol server that can result in Unauthorized data access. This attack appear to be exploitable via network connectivity. This vulnerability appears to have been fixed in 4.5.1.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2018-1000132?

3 open source packages ship an affected version, including mercurial. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mercurial` | PyPI | All versions | 4.5.1 |
| `mercurial` | PyPI | All versions | 4.5.1 |
| `mercurial` | PyPI | All versions | 4.5.1 |
| `mercurial` | SUSE:Linux Enterprise Software Development Kit 12 SP3 | All versions | 2.8.2-15.10.1 |

Products: Debian Debian Linux, Mercurial Mercurial.

## How do I fix CVE-2018-1000132?

Upgrade mercurial to 4.5.1 or later.

## Is CVE-2018-1000132 being exploited?

There is no known exploitation of CVE-2018-1000132 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000132 and fix it if it is affected.

What it is: CVE-2018-1000132 is a critical missing authorization vulnerability in Debian Debian Linux, published on 14 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000132 in the wild and no public exploit code.

Affected packages and fixed versions:
- mercurial (PyPI): affected all versions; fixed in 4.5.1
- mercurial (PyPI): affected all versions; fixed in 4.5.1
- mercurial (PyPI): affected all versions; fixed in 4.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000132/ (Markdown: https://insights.sbomify.com/CVE-2018-1000132/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000132
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000132
- OSV: https://osv.dev/vulnerability/CVE-2018-1000132

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000132/
Summaries are generated and may contain mistakes; the official description above is the record.
