CVE-2018-1000134 Weak Password Requirements in UnboundID LDAP SDK

Critical 9.8 Published Updated

Attackers can impersonate valid users by providing an empty password in synchronous mode due to missing validation in the LDAP SDK.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1000134?

CVE-2018-1000134 is a critical authentication bypass vulnerability in n/a, published on 16 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

UnboundID LDAP SDK version from commit 801111d8b5c732266a5dbd4b3bb0b6c7b94d7afb up to commit 8471904a02438c03965d21367890276bc25fa5a6, where the issue was reported and fixed contains an Incorrect Access Control vulnerability in process function in SimpleBindRequest class doesn't check for empty password when running in synchronous mode. commit with applied fix https://github.com/pingidentity/ldapsdk/commit/8471904a02438c03965d21367890276bc25fa5a6#diff-f6cb23b459be1ec17df1da33760087fd that can result in Ability to impersonate any valid user. This attack appear to be exploitable via Providing valid username and empty password against servers that do not do additional validation as per https://tools.ietf.org/html/rfc4513#section-5.1.1. This vulnerability appears to have been fixed in after commit 8471904a02438c03965d21367890276bc25fa5a6.

Weakness: CWE-521

Which versions are affected by CVE-2018-1000134?

2 open source packages ship an affected version, including com.unboundid:unboundid-ldapsdk. It affects 1 product.

PackageAffectedFixed in
com.unboundid:unboundid-ldapsdk MavenFrom 1.1.04.0.5
com.unboundid:unboundid-ldapsdk MavenFrom 1.1.04.0.5
Linux distribution packages (2)
unboundid-ldapsdk Red Hat:rhev_manager:4All versions0:4.0.5-1.el7ev
unboundid-ldapsdk-javadoc Red Hat:rhev_manager:4All versions0:4.0.5-1.el7ev

Products include Pingidentity Ldapsdk.

How do I fix CVE-2018-1000134?

Upgrade com.unboundid:unboundid-ldapsdk to 4.0.5 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2018-1000134 being exploited?

There is no known exploitation of CVE-2018-1000134 in the wild and no public exploit code.

Sources

Also known as GHSA-qwq9-8rpf-8mp7, RHSA-2018:1713.

Is CVE-2018-1000134 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free