# CVE-2018-1000143: Jenkins GitHub Pull Request Builder Plugin

> An attacker with local file system access can obtain GitHub credentials from the Jenkins GitHub Pull Request Builder Plugin.

- **Severity:** Medium 6.7 (`CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Apr 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-876j-4q73-7f56

## What is CVE-2018-1000143?

CVE-2018-1000143 is a medium-severity vulnerability in n/a, published on 5 Apr 2018. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An exposure of sensitive information vulnerability exists in Jenkins GitHub Pull Request Builder Plugin version 1.39.0 and older in GhprbCause.java that allows an attacker with local file system access to obtain GitHub credentials.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2018-1000143?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:ghprb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:ghprb` | Maven | All versions | 1.32.1 |
| `org.jenkins-ci.plugins:ghprb` | Maven | All versions | 1.32.1 |

Products: Jenkins Github Pull Request Builder.

## How do I fix CVE-2018-1000143?

Upgrade org.jenkins-ci.plugins:ghprb to 1.32.1 or later.

## Is CVE-2018-1000143 being exploited?

There is no known exploitation of CVE-2018-1000143 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-24434](https://insights.sbomify.com/CVE-2023-24434/): CSRF vulnerability in Jenkins GitHub Pull Request Builder Plugin (high 8.8)
- [CVE-2018-1000142](https://insights.sbomify.com/CVE-2018-1000142/): Jenkins GitHub Pull Request Builder Plugin allows attacker with local file system access to obtain GitHub credentials (high 7.8)
- [CVE-2023-24435](https://insights.sbomify.com/CVE-2023-24435/): Missing permission checks in Jenkins GitHub Pull Request Builder Plugin (medium 6.5)
- [CVE-2018-1000186](https://insights.sbomify.com/CVE-2018-1000186/): Jenkins GitHub Pull Request Builder Plugin credential capture vulnerability (medium 6.5)
- [CVE-2023-24436](https://insights.sbomify.com/CVE-2023-24436/): Jenkins GitHub Pull Request Builder Plugin missing permission check allows enumerating credentials IDs (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000143 and fix it if it is affected.

What it is: CVE-2018-1000143 is a medium-severity vulnerability in n/a, published on 5 Apr 2018. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000143 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:ghprb (Maven): affected all versions; fixed in 1.32.1
- org.jenkins-ci.plugins:ghprb (Maven): affected all versions; fixed in 1.32.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000143/ (Markdown: https://insights.sbomify.com/CVE-2018-1000143/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000143
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000143
- OSV: https://osv.dev/vulnerability/CVE-2018-1000143

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000143/
Summaries are generated and may contain mistakes; the official description above is the record.
