{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:liquibase-runner. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000146 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:liquibase-runner to 1.4.3 or later.","what":"CVE-2018-1000146 is a high-severity code injection vulnerability in n/a, published on 5 Apr 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000146 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000146 is a high-severity code injection vulnerability in n/a, published on 5 Apr 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000146 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:liquibase-runner (Maven): affected all versions; fixed in 1.4.3\n- org.jenkins-ci.plugins:liquibase-runner (Maven): affected all versions; fixed in 1.4.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000146/ (Markdown: https://insights.sbomify.com/CVE-2018-1000146/index.md)","id":"CVE-2018-1000146","markdown":"https://insights.sbomify.com/CVE-2018-1000146/index.md","name":"CVE-2018-1000146","record":{"aliases":["GHSA-3hvc-xwjp-xr8m"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"low_privilege","summary":"An attacker with job configuration permissions can execute arbitrary code on the Jenkins master JVM via the Liquibase Runner Plugin.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"liquibase_runner","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[],"description":"An arbitrary code execution vulnerability exists in Liquibase Runner Plugin version 1.3.0 and older that allows an attacker with permission to configure jobs to load and execute arbitrary code on the Jenkins master JVM.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Liquibase Runner Plugin allows users to load arbitrary Java code into controller JVM","id":"CVE-2018-1000146","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins Perforce Plugin exposure of sensitive information vulnerability exists","id":"CVE-2018-1000147"},"packages":[{"ecosystem":"Maven","fixed":["1.4.3"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:liquibase-runner","purl":null,"source":"GHSA-3hvc-xwjp-xr8m"},{"ecosystem":"Maven","fixed":["1.4.3"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:liquibase-runner","purl":"pkg:maven/org.jenkins-ci.plugins/liquibase-runner","source":"GHSA-3hvc-xwjp-xr8m"}],"prev":{"headline":"Jenkins Perforce Plugin uses ineffective credentials encryption","id":"CVE-2018-1000145"},"products":["n/a"],"published":"2018-04-05","related":[{"cvss_score":7.1,"headline":"XXE vulnerability in Jenkins Liquibase Runner Plugin","id":"CVE-2020-2284","kev_date_added":null,"published":"2020-09-23"},{"cvss_score":5.4,"headline":"Stored XSS vulnerability in Jenkins Liquibase Runner Plugin","id":"CVE-2020-2283","kev_date_added":null,"published":"2020-09-23"},{"cvss_score":4.3,"headline":"Missing permission check in Jenkins Liquibase Runner Plugin allows enumerating credentials IDs","id":"CVE-2020-2285","kev_date_added":null,"published":"2020-09-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"An attacker with job configuration permissions can execute arbitrary code on the Jenkins master JVM via the Liquibase Runner Plugin.","url":"https://insights.sbomify.com/CVE-2018-1000146/"}