# CVE-2018-1000146: Liquibase Runner Plugin allows users to load arbitrary Java code into controller JVM

> An attacker with job configuration permissions can execute arbitrary code on the Jenkins master JVM via the Liquibase Runner Plugin.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Apr 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-3hvc-xwjp-xr8m

## What is CVE-2018-1000146?

CVE-2018-1000146 is a high-severity code injection vulnerability in n/a, published on 5 Apr 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An arbitrary code execution vulnerability exists in Liquibase Runner Plugin version 1.3.0 and older that allows an attacker with permission to configure jobs to load and execute arbitrary code on the Jenkins master JVM.

## Which versions are affected by CVE-2018-1000146?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:liquibase-runner. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:liquibase-runner` | Maven | All versions | 1.4.3 |
| `org.jenkins-ci.plugins:liquibase-runner` | Maven | All versions | 1.4.3 |

Products: Jenkins Liquibase Runner.

## How do I fix CVE-2018-1000146?

Upgrade org.jenkins-ci.plugins:liquibase-runner to 1.4.3 or later.

## Is CVE-2018-1000146 being exploited?

There is no known exploitation of CVE-2018-1000146 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-2284](https://insights.sbomify.com/CVE-2020-2284/): XXE vulnerability in Jenkins Liquibase Runner Plugin (high 7.1)
- [CVE-2020-2283](https://insights.sbomify.com/CVE-2020-2283/): Stored XSS vulnerability in Jenkins Liquibase Runner Plugin (medium 5.4)
- [CVE-2020-2285](https://insights.sbomify.com/CVE-2020-2285/): Missing permission check in Jenkins Liquibase Runner Plugin allows enumerating credentials IDs (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000146 and fix it if it is affected.

What it is: CVE-2018-1000146 is a high-severity code injection vulnerability in n/a, published on 5 Apr 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000146 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:liquibase-runner (Maven): affected all versions; fixed in 1.4.3
- org.jenkins-ci.plugins:liquibase-runner (Maven): affected all versions; fixed in 1.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000146/ (Markdown: https://insights.sbomify.com/CVE-2018-1000146/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000146
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000146
- OSV: https://osv.dev/vulnerability/CVE-2018-1000146

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000146/
Summaries are generated and may contain mistakes; the official description above is the record.
