# CVE-2018-1000152: Jenkins vSphere Plugin incorrect authorization vulnerability

> Attackers can bypass authorization to trigger vSphere server requests causing denial of service or exfiltrate stored credentials to attacker-controlled servers.

- **Severity:** Medium 6.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Apr 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-48pq-x3vw-4pqf

## What is CVE-2018-1000152?

CVE-2018-1000152 is a medium-severity missing authorization vulnerability in n/a, published on 5 Apr 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An improper authorization vulnerability exists in Jenkins vSphere Plugin 2.16 and older in Clone.java, CloudSelectorParameter.java, ConvertToTemplate.java, ConvertToVm.java, Delete.java, DeleteSnapshot.java, Deploy.java, ExposeGuestInfo.java, FolderVSphereCloudProperty.java, PowerOff.java, PowerOn.java, Reconfigure.java, Rename.java, RenameSnapshot.java, RevertToSnapshot.java, SuspendVm.java, TakeSnapshot.java, VSphereBuildStepContainer.java, vSphereCloudProvisionedSlave.java, vSphereCloudSlave.java, vSphereCloudSlaveTemplate.java, VSphereConnectionConfig.java, vSphereStep.java that allows attackers to perform form validation related actions, including sending numerous requests to the configured vSphere server, potentially resulting in denial of service, or send credentials stored in Jenkins with known ID to an attacker-specified server ("test connection").

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2018-1000152?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:vsphere-cloud. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:vsphere-cloud` | Maven | All versions | 2.17 |
| `org.jenkins-ci.plugins:vsphere-cloud` | Maven | All versions | 2.17 |

Products: Jenkins Vsphere.

## How do I fix CVE-2018-1000152?

Upgrade org.jenkins-ci.plugins:vsphere-cloud to 2.17 or later.

## Is CVE-2018-1000152 being exploited?

There is no known exploitation of CVE-2018-1000152 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-1000153](https://insights.sbomify.com/CVE-2018-1000153/): Jenkins vSphere Plugin Cross-Site Request Forgery vulnerability (high 8.8)
- [CVE-2018-1000151](https://insights.sbomify.com/CVE-2018-1000151/): Jenkins vSphere Plugin disables SSL/TLS certificate validation by default (medium 5.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000152 and fix it if it is affected.

What it is: CVE-2018-1000152 is a medium-severity missing authorization vulnerability in n/a, published on 5 Apr 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000152 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:vsphere-cloud (Maven): affected all versions; fixed in 2.17
- org.jenkins-ci.plugins:vsphere-cloud (Maven): affected all versions; fixed in 2.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000152/ (Markdown: https://insights.sbomify.com/CVE-2018-1000152/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000152
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000152
- OSV: https://osv.dev/vulnerability/CVE-2018-1000152

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000152/
Summaries are generated and may contain mistakes; the official description above is the record.
