{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:vsphere-cloud. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000153 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:vsphere-cloud to 2.17 or later.","what":"CVE-2018-1000153 is a high-severity vulnerability in n/a, published on 5 Apr 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-1000153 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000153 is a high-severity vulnerability in n/a, published on 5 Apr 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-1000153 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:vsphere-cloud (Maven): affected all versions; fixed in 2.17\n- org.jenkins-ci.plugins:vsphere-cloud (Maven): affected all versions; fixed in 2.17\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000153/ (Markdown: https://insights.sbomify.com/CVE-2018-1000153/index.md)","id":"CVE-2018-1000153","markdown":"https://insights.sbomify.com/CVE-2018-1000153/index.md","name":"CVE-2018-1000153","record":{"aliases":["GHSA-2g32-2j8w-2qgf"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["denial_of_service","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins vSphere Plugin","requires_auth":"none","summary":"Attackers can exploit CSRF to trigger vSphere actions causing denial of service or exfiltrate stored credentials to attacker-controlled servers.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"vsphere","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"A cross-site request forgery vulnerability exists in Jenkins vSphere Plugin 2.16 and older in Clone.java, CloudSelectorParameter.java, ConvertToTemplate.java, ConvertToVm.java, Delete.java, DeleteSnapshot.java, Deploy.java, ExposeGuestInfo.java, FolderVSphereCloudProperty.java, PowerOff.java, PowerOn.java, Reconfigure.java, Rename.java, RenameSnapshot.java, RevertToSnapshot.java, SuspendVm.java, TakeSnapshot.java, VSphereBuildStepContainer.java, vSphereCloudProvisionedSlave.java, vSphereCloudSlave.java, vSphereCloudSlaveTemplate.java, VSphereConnectionConfig.java, vSphereStep.java that allows attackers to perform form validation related actions, including sending numerous requests to the configured vSphere server, potentially resulting in denial of service, or send credentials stored in Jenkins with known ID to an attacker-specified server (\"test connection\").","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins vSphere Plugin Cross-Site Request Forgery vulnerability","id":"CVE-2018-1000153","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-1000154"},"packages":[{"ecosystem":"Maven","fixed":["2.17"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:vsphere-cloud","purl":null,"source":"GHSA-2g32-2j8w-2qgf"},{"ecosystem":"Maven","fixed":["2.17"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:vsphere-cloud","purl":"pkg:maven/org.jenkins-ci.plugins/vsphere-cloud","source":"GHSA-2g32-2j8w-2qgf"}],"prev":{"headline":"Jenkins vSphere Plugin incorrect authorization vulnerability","id":"CVE-2018-1000152"},"products":["n/a"],"published":"2018-04-05","related":[{"cvss_score":6.3,"headline":"Jenkins vSphere Plugin incorrect authorization vulnerability","id":"CVE-2018-1000152","kev_date_added":null,"published":"2018-04-05"},{"cvss_score":5.6,"headline":"Jenkins vSphere Plugin disables SSL/TLS certificate validation by default","id":"CVE-2018-1000151","kev_date_added":null,"published":"2018-04-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can exploit CSRF to trigger vSphere actions causing denial of service or exfiltrate stored credentials to attacker-controlled servers.","url":"https://insights.sbomify.com/CVE-2018-1000153/"}