{"answers":{"affected":"3 open source packages ship an affected version, including tlslite-ng. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000159 in the wild and no public exploit code.","fix":"Upgrade tlslite-ng to 0.7.4 or later.","what":"CVE-2018-1000159 is a medium-severity vulnerability in n/a, published on 18 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000159 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000159 is a medium-severity vulnerability in n/a, published on 18 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000159 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- tlslite-ng (PyPI): affected all versions; fixed in 0.7.4\n- tlslite-ng (PyPI): affected all versions; fixed in 0.7.4\n- tlslite-ng (PyPI): affected all versions; fixed in 0.7.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000159/ (Markdown: https://insights.sbomify.com/CVE-2018-1000159/index.md)","id":"CVE-2018-1000159","markdown":"https://insights.sbomify.com/CVE-2018-1000159/index.md","name":"CVE-2018-1000159","record":{"aliases":["GHSA-cwh5-3cw7-4286","PYSEC-2018-31","UBUNTU-CVE-2018-1000159"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python TLS library","requires_auth":"none","summary":"An attacker can manipulate TLS ciphertext without detection due to improper integrity check validation in tlslite-ng.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"tlslite-ng","vendor":"tlslite-ng_project"}],"cvss":{"score":5.9,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-354","name":"Improper Validation of Integrity Check Value"}],"description":"tlslite-ng version 0.7.3 and earlier, since commit d7b288316bca7bcdd082e6ccff5491e241305233 contains a CWE-354: Improper Validation of Integrity Check Value vulnerability in TLS implementation, tlslite/utils/constanttime.py: ct_check_cbc_mac_and_pad(); line \"end_pos = data_len - 1 - mac.digest_size\" that can result in an attacker manipulating the TLS ciphertext which will not be detected by receiving tlslite-ng. This attack appears to be exploitable via man in the middle on a network connection. This vulnerability appears to have been fixed after commit 3674815d1b0f7484454995e2737a352e0a6a93d8.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"tlslite-ng off-by-one error on mac checking","id":"CVE-2018-1000159","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"other","year":"2018"},"n_packages":3,"n_references":1,"next":{"headline":"Cross-Site Scripting in @risingstack/protect","id":"CVE-2018-1000160"},"packages":[{"ecosystem":"PyPI","fixed":["0.7.4"],"introduced":["0"],"last_affected":[],"package":"tlslite-ng","purl":null,"source":"GHSA-cwh5-3cw7-4286"},{"ecosystem":"PyPI","fixed":["0.7.4"],"introduced":["0"],"last_affected":[],"package":"tlslite-ng","purl":"pkg:pypi/tlslite-ng","source":"GHSA-cwh5-3cw7-4286"},{"ecosystem":"PyPI","fixed":["0.7.4"],"introduced":["0"],"last_affected":[],"package":"tlslite-ng","purl":"pkg:pypi/tlslite-ng","source":"PYSEC-2018-31"}],"prev":{"headline":"Open redirect in n/a","id":"CVE-2018-1000158"},"products":["n/a"],"published":"2018-04-18","related":[{"cvss_score":7.5,"headline":"RSA vulnerability in tslite-ng","id":"CVE-2020-26263","kev_date_added":null,"published":"2020-12-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker can manipulate TLS ciphertext without detection due to improper integrity check validation in tlslite-ng.","url":"https://insights.sbomify.com/CVE-2018-1000159/"}