# CVE-2018-1000161: Path traversal in n/a

> An attacker can overwrite files by tricking a user into running the http-fetch NSE script against a malicious website.

- **Severity:** Medium 5.7 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Apr 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-1000161, GHSA-463f-727w-pqp7, UBUNTU-CVE-2018-1000161

## What is CVE-2018-1000161?

CVE-2018-1000161 is a medium-severity path traversal vulnerability in n/a, published on 18 Apr 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

nmap version 6.49BETA6 through 7.60, up to and including SVN revision 37147 contains a Directory Traversal vulnerability in NSE script http-fetch that can result in file overwrite as the user is running it. This attack appears to be exploitable via a victim that runs NSE script http-fetch against a malicious web site. This vulnerability appears to have been fixed in 7.7.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2018-1000161?

It affects 1 product.


Products: Nmap Nmap.

## How do I fix CVE-2018-1000161?

Upgrade to a fixed version.

## Is CVE-2018-1000161 being exploited?

There is no known exploitation of CVE-2018-1000161 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-18594](https://insights.sbomify.com/CVE-2017-18594/): Memory corruption in n/a (high 7.5)
- [CVE-2018-15173](https://insights.sbomify.com/CVE-2018-15173/): Denial of service in n/a (high 7.5)
- [CVE-2026-58058](https://insights.sbomify.com/CVE-2026-58058/): Nmap - Integer Underflow in IPv6 Extension Header Parsing (medium 6.9)
- [CVE-2013-4885](https://insights.sbomify.com/CVE-2013-4885/): Path traversal in n/a (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000161 and fix it if it is affected.

What it is: CVE-2018-1000161 is a medium-severity path traversal vulnerability in n/a, published on 18 Apr 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-1000161 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000161/ (Markdown: https://insights.sbomify.com/CVE-2018-1000161/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000161
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000161
- OSV: https://osv.dev/vulnerability/CVE-2018-1000161

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000161/
Summaries are generated and may contain mistakes; the official description above is the record.
