{"answers":{"affected":"2 open source packages ship an affected version, including erusev/parsedown. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000162 in the wild and no public exploit code.","fix":"Upgrade erusev/parsedown to 1.7.0 or later.","what":"CVE-2018-1000162 is a medium-severity cross-site scripting vulnerability in n/a, published on 18 Apr 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-1000162 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000162 is a medium-severity cross-site scripting vulnerability in n/a, published on 18 Apr 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-1000162 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- erusev/parsedown (Packagist): affected all versions; fixed in 1.7.0\n- erusev/parsedown (Packagist): affected all versions; fixed in 1.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000162/ (Markdown: https://insights.sbomify.com/CVE-2018-1000162/index.md)","id":"CVE-2018-1000162","markdown":"https://insights.sbomify.com/CVE-2018-1000162/index.md","name":"CVE-2018-1000162","record":{"aliases":["CLSA-2026-1790249242","GHSA-qgpv-86r3-87fh"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP Markdown parser","requires_auth":"none","summary":"Attackers can execute JavaScript via crafted markdown in Parsedown due to improper HTML escaping, affecting applications using this library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"parsedown","vendor":"parsedown"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Parsedown version prior to 1.7.0 contains a Cross Site Scripting (XSS) vulnerability in `setMarkupEscaped` for escaping HTML that can result in JavaScript code execution. This attack appears to be exploitable via specially crafted markdown that allows it to side step HTML escaping by breaking AST boundaries. This vulnerability appears to have been fixed in 1.7.0 and later.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in Parsedown","id":"CVE-2018-1000162","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-1000163"},"packages":[{"ecosystem":"Packagist","fixed":["1.7.0"],"introduced":["0"],"last_affected":[],"package":"erusev/parsedown","purl":null,"source":"GHSA-qgpv-86r3-87fh"},{"ecosystem":"Packagist","fixed":["1.7.0"],"introduced":["0"],"last_affected":[],"package":"erusev/parsedown","purl":"pkg:composer/erusev/parsedown","source":"GHSA-qgpv-86r3-87fh"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2018-1000161"},"products":["n/a"],"published":"2018-04-18","related":[{"cvss_score":8.1,"headline":"Parsedown Class-Name Injection","id":"CVE-2019-10905","kev_date_added":null,"published":"2019-04-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can execute JavaScript via crafted markdown in Parsedown due to improper HTML escaping, affecting applications using this library.","url":"https://insights.sbomify.com/CVE-2018-1000162/"}