# CVE-2018-1000162: Cross-site Scripting in Parsedown

> Attackers can execute JavaScript via crafted markdown in Parsedown due to improper HTML escaping, affecting applications using this library.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Apr 2018
- **Updated:** 5 Aug 2024
- **Also known as:** CLSA-2026-1790249242, GHSA-qgpv-86r3-87fh

## What is CVE-2018-1000162?

CVE-2018-1000162 is a medium-severity cross-site scripting vulnerability in n/a, published on 18 Apr 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Parsedown version prior to 1.7.0 contains a Cross Site Scripting (XSS) vulnerability in `setMarkupEscaped` for escaping HTML that can result in JavaScript code execution. This attack appears to be exploitable via specially crafted markdown that allows it to side step HTML escaping by breaking AST boundaries. This vulnerability appears to have been fixed in 1.7.0 and later.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-1000162?

2 open source packages ship an affected version, including erusev/parsedown. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `erusev/parsedown` | Packagist | All versions | 1.7.0 |
| `erusev/parsedown` | Packagist | All versions | 1.7.0 |

Products: Parsedown Parsedown.

## How do I fix CVE-2018-1000162?

Upgrade erusev/parsedown to 1.7.0 or later.

## Is CVE-2018-1000162 being exploited?

There is no known exploitation of CVE-2018-1000162 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-10905](https://insights.sbomify.com/CVE-2019-10905/): Parsedown Class-Name Injection (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000162 and fix it if it is affected.

What it is: CVE-2018-1000162 is a medium-severity cross-site scripting vulnerability in n/a, published on 18 Apr 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-1000162 in the wild and no public exploit code.

Affected packages and fixed versions:
- erusev/parsedown (Packagist): affected all versions; fixed in 1.7.0
- erusev/parsedown (Packagist): affected all versions; fixed in 1.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000162/ (Markdown: https://insights.sbomify.com/CVE-2018-1000162/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000162
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000162
- OSV: https://osv.dev/vulnerability/CVE-2018-1000162

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000162/
Summaries are generated and may contain mistakes; the official description above is the record.
