# CVE-2018-1000164: Gunicorn contains Improper Neutralization of CRLF sequences in HTTP headers

> An attacker can inject arbitrary HTTP headers via CRLF sequences in gunicorn, potentially leading to cache poisoning or security bypasses.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Apr 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-1000164, DLA-1357-1, DSA-4186-1, GHSA-32pc-xphx-q4f6, PYSEC-2018-55, UBUNTU-CVE-2018-1000164, USN-4022-1

## What is CVE-2018-1000164?

CVE-2018-1000164 is a high-severity vulnerability in Debian Debian Linux, published on 18 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

gunicorn version 19.4.5 contains a CWE-113: Improper Neutralization of CRLF Sequences in HTTP Headers vulnerability in "process_headers" function in "gunicorn/http/wsgi.py" that can result in an attacker causing the server to return arbitrary HTTP headers. This vulnerability appears to have been fixed in 19.5.0.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences)

## Which versions are affected by CVE-2018-1000164?

3 open source packages ship an affected version, including gunicorn. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gunicorn` | PyPI | All versions | 19.5.0 |
| `gunicorn` | PyPI | All versions | 19.5.0 |
| `gunicorn` | PyPI | All versions | 19.5.0 |

Products: Debian Debian Linux, Gunicorn Gunicorn.

## How do I fix CVE-2018-1000164?

Upgrade gunicorn to 19.5.0 or later.

## Is CVE-2018-1000164 being exploited?

There is no known exploitation of CVE-2018-1000164 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000164 and fix it if it is affected.

What it is: CVE-2018-1000164 is a high-severity vulnerability in Debian Debian Linux, published on 18 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000164 in the wild and no public exploit code.

Affected packages and fixed versions:
- gunicorn (PyPI): affected all versions; fixed in 19.5.0
- gunicorn (PyPI): affected all versions; fixed in 19.5.0
- gunicorn (PyPI): affected all versions; fixed in 19.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000164/ (Markdown: https://insights.sbomify.com/CVE-2018-1000164/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000164
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000164
- OSV: https://osv.dev/vulnerability/CVE-2018-1000164

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000164/
Summaries are generated and may contain mistakes; the official description above is the record.
