{"answers":{"affected":"2 open source packages ship an affected version, including lightsaml/lightsaml. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000165 in the wild and no public exploit code.","fix":"Upgrade lightsaml/lightsaml to 1.3.5 or later.","what":"CVE-2018-1000165 is a high-severity authentication bypass vulnerability in n/a, published on 18 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000165 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000165 is a high-severity authentication bypass vulnerability in n/a, published on 18 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000165 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- lightsaml/lightsaml (Packagist): affected all versions; fixed in 1.3.5\n- lightsaml/lightsaml (Packagist): affected all versions; fixed in 1.3.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000165/ (Markdown: https://insights.sbomify.com/CVE-2018-1000165/index.md)","id":"CVE-2018-1000165","markdown":"https://insights.sbomify.com/CVE-2018-1000165/index.md","name":"CVE-2018-1000165","record":{"aliases":["GHSA-vg4f-8v9q-5c3x"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"LightSAML PHP library","requires_auth":"none","summary":"Attackers can impersonate any user from the Identity Provider due to incorrect signature validation in the LightSAML library.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"lightsaml","vendor":"lightsaml"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-732","name":"Incorrect Permission Assignment for Critical Resource"}],"description":"LightSAML version prior to 1.3.5 contains a Incorrect Access Control vulnerability in signature validation in readers in src/LightSaml/Model/XmlDSig/ that can result in impersonation of any user from Identity Provider. This vulnerability appears to have been fixed in 1.3.5 and later.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"LightSAML Incorrect Access Control vulnerability","id":"CVE-2018-1000165","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"OISF suricata-update unsafely deserializes YAML data","id":"CVE-2018-1000167"},"packages":[{"ecosystem":"Packagist","fixed":["1.3.5"],"introduced":["0"],"last_affected":[],"package":"lightsaml/lightsaml","purl":null,"source":"GHSA-vg4f-8v9q-5c3x"},{"ecosystem":"Packagist","fixed":["1.3.5"],"introduced":["0"],"last_affected":[],"package":"lightsaml/lightsaml","purl":"pkg:composer/lightsaml/lightsaml","source":"GHSA-vg4f-8v9q-5c3x"}],"prev":{"headline":"Gunicorn contains Improper Neutralization of CRLF sequences in HTTP headers","id":"CVE-2018-1000164"},"products":["n/a"],"published":"2018-04-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can impersonate any user from the Identity Provider due to incorrect signature validation in the LightSAML library.","url":"https://insights.sbomify.com/CVE-2018-1000165/"}