# CVE-2018-1000165: LightSAML Incorrect Access Control vulnerability

> Attackers can impersonate any user from the Identity Provider due to incorrect signature validation in the LightSAML library.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Apr 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-vg4f-8v9q-5c3x

## What is CVE-2018-1000165?

CVE-2018-1000165 is a high-severity authentication bypass vulnerability in n/a, published on 18 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

LightSAML version prior to 1.3.5 contains a Incorrect Access Control vulnerability in signature validation in readers in src/LightSaml/Model/XmlDSig/ that can result in impersonation of any user from Identity Provider. This vulnerability appears to have been fixed in 1.3.5 and later.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2018-1000165?

2 open source packages ship an affected version, including lightsaml/lightsaml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lightsaml/lightsaml` | Packagist | All versions | 1.3.5 |
| `lightsaml/lightsaml` | Packagist | All versions | 1.3.5 |

Products: Lightsaml Lightsaml.

## How do I fix CVE-2018-1000165?

Upgrade lightsaml/lightsaml to 1.3.5 or later.

## Is CVE-2018-1000165 being exploited?

There is no known exploitation of CVE-2018-1000165 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000165 and fix it if it is affected.

What it is: CVE-2018-1000165 is a high-severity authentication bypass vulnerability in n/a, published on 18 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000165 in the wild and no public exploit code.

Affected packages and fixed versions:
- lightsaml/lightsaml (Packagist): affected all versions; fixed in 1.3.5
- lightsaml/lightsaml (Packagist): affected all versions; fixed in 1.3.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000165/ (Markdown: https://insights.sbomify.com/CVE-2018-1000165/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000165
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000165
- OSV: https://osv.dev/vulnerability/CVE-2018-1000165

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000165/
Summaries are generated and may contain mistakes; the official description above is the record.
