{"answers":{"affected":"3 open source packages ship an affected version, including suricata-update. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000167 in the wild and no public exploit code.","fix":"Upgrade suricata-update to 1.0.0b1 or later.","what":"CVE-2018-1000167 is a high-severity unsafe deserialization vulnerability in n/a, published on 18 Apr 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-1000167 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000167 is a high-severity unsafe deserialization vulnerability in n/a, published on 18 Apr 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-1000167 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- suricata-update (PyPI): affected all versions; fixed in 1.0.0b1\n- suricata-update (PyPI): affected all versions; fixed in 1.0.0b1\n- suricata-update (PyPI): affected all versions; fixed in 1.0.0b1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000167/ (Markdown: https://insights.sbomify.com/CVE-2018-1000167/index.md)","id":"CVE-2018-1000167","markdown":"https://insights.sbomify.com/CVE-2018-1000167/index.md","name":"CVE-2018-1000167","record":{"aliases":["GHSA-7c4h-w765-6pwg","PYSEC-2018-75"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python suricata-update library","requires_auth":"none","summary":"An insecure deserialization vulnerability in suricata-update allows remote code execution via a crafted YAML file, requiring an upgrade to the latest version.","user_interaction":"required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"suricata-update","vendor":"oisf"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"OISF suricata-update version 1.0.0a1 contains an Insecure Deserialization vulnerability in the insecure yaml.load-Function as used in the following files: config.py:136, config.py:142, sources.py:99 and sources.py:131. The \"list-sources\"-command is affected by this bug. that can result in Remote Code Execution(even as root if suricata-update is called by root). This attack appears to be exploitable via a specially crafted yaml-file at https://www.openinfosecfoundation.org/rules/index.yaml. This vulnerability appears to have been fixed in 1.0.0b1.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OISF suricata-update unsafely deserializes YAML data","id":"CVE-2018-1000167","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2018"},"n_packages":3,"n_references":2,"next":{"headline":"Denial of service in n/a","id":"CVE-2018-1000168"},"packages":[{"ecosystem":"PyPI","fixed":["1.0.0b1"],"introduced":["0"],"last_affected":[],"package":"suricata-update","purl":null,"source":"GHSA-7c4h-w765-6pwg"},{"ecosystem":"PyPI","fixed":["1.0.0b1"],"introduced":["0"],"last_affected":[],"package":"suricata-update","purl":"pkg:pypi/suricata-update","source":"GHSA-7c4h-w765-6pwg"},{"ecosystem":"PyPI","fixed":["1.0.0b1"],"introduced":["0"],"last_affected":[],"package":"suricata-update","purl":"pkg:pypi/suricata-update","source":"PYSEC-2018-75"}],"prev":{"headline":"LightSAML Incorrect Access Control vulnerability","id":"CVE-2018-1000165"},"products":["n/a"],"published":"2018-04-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An insecure deserialization vulnerability in suricata-update allows remote code execution via a crafted YAML file, requiring an upgrade to the latest version.","url":"https://insights.sbomify.com/CVE-2018-1000167/"}