# CVE-2018-1000167: OISF suricata-update unsafely deserializes YAML data

> An insecure deserialization vulnerability in suricata-update allows remote code execution via a crafted YAML file, requiring an upgrade to the latest version.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Apr 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-7c4h-w765-6pwg, PYSEC-2018-75

## What is CVE-2018-1000167?

CVE-2018-1000167 is a high-severity unsafe deserialization vulnerability in n/a, published on 18 Apr 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

OISF suricata-update version 1.0.0a1 contains an Insecure Deserialization vulnerability in the insecure yaml.load-Function as used in the following files: config.py:136, config.py:142, sources.py:99 and sources.py:131. The "list-sources"-command is affected by this bug. that can result in Remote Code Execution(even as root if suricata-update is called by root). This attack appears to be exploitable via a specially crafted yaml-file at https://www.openinfosecfoundation.org/rules/index.yaml. This vulnerability appears to have been fixed in 1.0.0b1.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2018-1000167?

3 open source packages ship an affected version, including suricata-update. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `suricata-update` | PyPI | All versions | 1.0.0b1 |
| `suricata-update` | PyPI | All versions | 1.0.0b1 |
| `suricata-update` | PyPI | All versions | 1.0.0b1 |

Products: Oisf Suricata-Update.

## How do I fix CVE-2018-1000167?

Upgrade suricata-update to 1.0.0b1 or later.

## Is CVE-2018-1000167 being exploited?

There is no known exploitation of CVE-2018-1000167 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000167 and fix it if it is affected.

What it is: CVE-2018-1000167 is a high-severity unsafe deserialization vulnerability in n/a, published on 18 Apr 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-1000167 in the wild and no public exploit code.

Affected packages and fixed versions:
- suricata-update (PyPI): affected all versions; fixed in 1.0.0b1
- suricata-update (PyPI): affected all versions; fixed in 1.0.0b1
- suricata-update (PyPI): affected all versions; fixed in 1.0.0b1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000167/ (Markdown: https://insights.sbomify.com/CVE-2018-1000167/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000167
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000167
- OSV: https://osv.dev/vulnerability/CVE-2018-1000167

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000167/
Summaries are generated and may contain mistakes; the official description above is the record.
