CVE-2018-1000168 Denial of service in n/a

High 7.5 Published Updated

A remote attacker can cause a segmentation fault and denial of service in nghttp2 by sending a malformed ALTSVC frame.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1000168?

CVE-2018-1000168 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 8 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.

Weakness: CWE-20, CWE-476

Which versions are affected by CVE-2018-1000168?

It affects 3 products.

Products include Debian Debian Linux, Nghttp2 Nghttp2, Nodejs Node.js.

How do I fix CVE-2018-1000168?

Upgrade to a fixed version.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2018-1000168 being exploited?

There is no known exploitation of CVE-2018-1000168 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as ALPINE-CVE-2018-1000168, CLEANSTART-2026-PZ96090, CLEANSTART-2026-QW15283, DEBIAN-CVE-2018-1000168, GHSA-q6fc-wp2r-hvq3, UBUNTU-CVE-2018-1000168.

Is CVE-2018-1000168 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free