# CVE-2018-1000168: Denial of service in n/a

> A remote attacker can cause a segmentation fault and denial of service in nghttp2 by sending a malformed ALTSVC frame.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2018
- **Updated:** 9 Jun 2025
- **Also known as:** ALPINE-CVE-2018-1000168, CLEANSTART-2026-PZ96090, CLEANSTART-2026-QW15283, DEBIAN-CVE-2018-1000168, GHSA-q6fc-wp2r-hvq3, UBUNTU-CVE-2018-1000168

## What is CVE-2018-1000168?

CVE-2018-1000168 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 8 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.

Weakness: CWE-20 (Improper Input Validation), CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2018-1000168?

It affects 3 products.


Products: Debian Debian Linux, Nghttp2 Nghttp2, Nodejs Node.js.

## How do I fix CVE-2018-1000168?

Upgrade to a fixed version.

## Is CVE-2018-1000168 being exploited?

There is no known exploitation of CVE-2018-1000168 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000168 and fix it if it is affected.

What it is: CVE-2018-1000168 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 8 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000168 in the wild and no public exploit code.

Affected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000168/ (Markdown: https://insights.sbomify.com/CVE-2018-1000168/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000168
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000168
- OSV: https://osv.dev/vulnerability/CVE-2018-1000168

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000168/
Summaries are generated and may contain mistakes; the official description above is the record.
