{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:htmlpublisher. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000175 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:htmlpublisher to 1.16 or later.","what":"CVE-2018-1000175 is a medium-severity path traversal vulnerability in n/a, published on 8 May 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000175 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000175 is a medium-severity path traversal vulnerability in n/a, published on 8 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000175 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:htmlpublisher (Maven): affected all versions; fixed in 1.16\n- org.jenkins-ci.plugins:htmlpublisher (Maven): affected all versions; fixed in 1.16\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000175/ (Markdown: https://insights.sbomify.com/CVE-2018-1000175/index.md)","id":"CVE-2018-1000175","markdown":"https://insights.sbomify.com/CVE-2018-1000175/index.md","name":"CVE-2018-1000175","record":{"aliases":["GHSA-4x63-3p7q-xmh7"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins HTML Publisher Plugin","requires_auth":"low_privilege","summary":"Attackers with build configuration access can override arbitrary files on the Jenkins master via path traversal in the HTML Publisher plugin.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"html_publisher","vendor":"jenkins"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"A path traversal vulnerability exists in Jenkins HTML Publisher Plugin 1.15 and older in HtmlPublisherTarget.java that allows attackers able to configure the HTML Publisher build step to override arbitrary files on the Jenkins master.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins HTML Publisher Plugin path traversal vulnerability","id":"CVE-2018-1000175","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"path_traversal","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins Email Extension Plugin showed plain text SMTP password in configuration form field","id":"CVE-2018-1000176"},"packages":[{"ecosystem":"Maven","fixed":["1.16"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:htmlpublisher","purl":null,"source":"GHSA-4x63-3p7q-xmh7"},{"ecosystem":"Maven","fixed":["1.16"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:htmlpublisher","purl":"pkg:maven/org.jenkins-ci.plugins/htmlpublisher","source":"GHSA-4x63-3p7q-xmh7"}],"prev":{"headline":"Jenkins Google Login Plugin Open Redirect vulnerability","id":"CVE-2018-1000174"},"products":["n/a"],"published":"2018-05-08","related":[{"cvss_score":8,"headline":"Jenkins HTML Publisher Plugin has a XSS vulnerability in the legacy wrapper file","id":"CVE-2026-42524","kev_date_added":null,"published":"2026-04-29"},{"cvss_score":6.5,"headline":"Jenkins HTML Publisher Plugin does not properly sanitize input","id":"CVE-2024-28149","kev_date_added":null,"published":"2024-03-06"},{"cvss_score":6.3,"headline":"Jenkins HTML Publisher Plugin vulnerability displays controller file system information in its logs","id":"CVE-2025-53651","kev_date_added":null,"published":"2025-07-09"},{"cvss_score":5.4,"headline":"Jenkins HTML Publisher Plugin vulnerable to Cross-site Scripting","id":"CVE-2019-10432","kev_date_added":null,"published":"2019-10-01"},{"cvss_score":4.7,"headline":"Jenkins HTML Publisher Plugin Stored XSS vulnerability","id":"CVE-2024-28150","kev_date_added":null,"published":"2024-03-06"},{"cvss_score":4.3,"headline":"Jenkins HTML Publisher Plugin Path traversal vulnerability","id":"CVE-2024-28151","kev_date_added":null,"published":"2024-03-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers with build configuration access can override arbitrary files on the Jenkins master via path traversal in the HTML Publisher plugin.","url":"https://insights.sbomify.com/CVE-2018-1000175/"}