# CVE-2018-1000175: Jenkins HTML Publisher Plugin path traversal vulnerability

> Attackers with build configuration access can override arbitrary files on the Jenkins master via path traversal in the HTML Publisher plugin.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-4x63-3p7q-xmh7

## What is CVE-2018-1000175?

CVE-2018-1000175 is a medium-severity path traversal vulnerability in n/a, published on 8 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A path traversal vulnerability exists in Jenkins HTML Publisher Plugin 1.15 and older in HtmlPublisherTarget.java that allows attackers able to configure the HTML Publisher build step to override arbitrary files on the Jenkins master.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2018-1000175?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:htmlpublisher. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:htmlpublisher` | Maven | All versions | 1.16 |
| `org.jenkins-ci.plugins:htmlpublisher` | Maven | All versions | 1.16 |

Products: Jenkins Html Publisher.

## How do I fix CVE-2018-1000175?

Upgrade org.jenkins-ci.plugins:htmlpublisher to 1.16 or later.

## Is CVE-2018-1000175 being exploited?

There is no known exploitation of CVE-2018-1000175 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-42524](https://insights.sbomify.com/CVE-2026-42524/): Jenkins HTML Publisher Plugin has a XSS vulnerability in the legacy wrapper file (high 8.0)
- [CVE-2024-28149](https://insights.sbomify.com/CVE-2024-28149/): Jenkins HTML Publisher Plugin does not properly sanitize input (medium 6.5)
- [CVE-2025-53651](https://insights.sbomify.com/CVE-2025-53651/): Jenkins HTML Publisher Plugin vulnerability displays controller file system information in its logs (medium 6.3)
- [CVE-2019-10432](https://insights.sbomify.com/CVE-2019-10432/): Jenkins HTML Publisher Plugin vulnerable to Cross-site Scripting (medium 5.4)
- [CVE-2024-28150](https://insights.sbomify.com/CVE-2024-28150/): Jenkins HTML Publisher Plugin Stored XSS vulnerability (medium 4.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000175 and fix it if it is affected.

What it is: CVE-2018-1000175 is a medium-severity path traversal vulnerability in n/a, published on 8 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000175 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:htmlpublisher (Maven): affected all versions; fixed in 1.16
- org.jenkins-ci.plugins:htmlpublisher (Maven): affected all versions; fixed in 1.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000175/ (Markdown: https://insights.sbomify.com/CVE-2018-1000175/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000175
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000175
- OSV: https://osv.dev/vulnerability/CVE-2018-1000175

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000175/
Summaries are generated and may contain mistakes; the official description above is the record.
