{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:git. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000182 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:git to 3.9.1 or later.","what":"CVE-2018-1000182 is a medium-severity server-side request forgery vulnerability in n/a, published on 5 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000182 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000182 is a medium-severity server-side request forgery vulnerability in n/a, published on 5 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000182 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:git (Maven): affected all versions; fixed in 3.9.1\n- org.jenkins-ci.plugins:git (Maven): affected all versions; fixed in 3.9.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000182/ (Markdown: https://insights.sbomify.com/CVE-2018-1000182/index.md)","id":"CVE-2018-1000182","markdown":"https://insights.sbomify.com/CVE-2018-1000182/index.md","name":"CVE-2018-1000182","record":{"aliases":["GHSA-53wf-vqf9-cgf2"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Git Plugin","requires_auth":"low_privilege","summary":"Attackers with read access can force Jenkins to send GET requests to arbitrary URLs, potentially accessing internal resources.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"git","vendor":"jenkins"}],"cvss":{"score":6.4,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"A server-side request forgery vulnerability exists in Jenkins Git Plugin 3.9.0 and older in AssemblaWeb.java, GitBlitRepositoryBrowser.java, Gitiles.java, TFS2013GitRepositoryBrowser.java, ViewGitWeb.java that allows attackers with Overall/Read access to cause Jenkins to send a GET request to a specified URL.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Server-Side Request Forgery in Jenkins Git Plugin","id":"CVE-2018-1000182","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"ssrf","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins GitHub Plugin exposure of sensitive information vulnerability exists","id":"CVE-2018-1000183"},"packages":[{"ecosystem":"Maven","fixed":["3.9.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:git","purl":null,"source":"GHSA-53wf-vqf9-cgf2"},{"ecosystem":"Maven","fixed":["3.9.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:git","purl":"pkg:maven/org.jenkins-ci.plugins/git","source":"GHSA-53wf-vqf9-cgf2"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2018-1000181"},"products":["n/a"],"published":"2018-06-05","related":[{"cvss_score":8.8,"headline":"Lack of authentication mechanism in Jenkins Git Plugin webhook","id":"CVE-2022-36882","kev_date_added":null,"published":"2022-07-27"},{"cvss_score":7.5,"headline":"Lack of authentication mechanism in Jenkins Git Plugin webhook","id":"CVE-2022-36883","kev_date_added":null,"published":"2022-07-27"},{"cvss_score":7.5,"headline":"Path traversal in Jenkins Git Mercurial and Repo Plugins","id":"CVE-2022-30947","kev_date_added":null,"published":"2022-05-17"},{"cvss_score":7.5,"headline":"Cross-Site Request Forgery in Jenkins Git Plugin","id":"CVE-2017-1000092","kev_date_added":null,"published":"2017-10-04"},{"cvss_score":6.5,"headline":"Improper masking of credentials Jenkins in Git Plugin","id":"CVE-2022-38663","kev_date_added":null,"published":"2022-08-23"},{"cvss_score":6.1,"headline":"Stored XSS vulnerability in Jenkins Git Plugin","id":"CVE-2021-21684","kev_date_added":null,"published":"2021-10-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers with read access can force Jenkins to send GET requests to arbitrary URLs, potentially accessing internal resources.","url":"https://insights.sbomify.com/CVE-2018-1000182/"}