# CVE-2018-1000182: Server-Side Request Forgery in Jenkins Git Plugin

> Attackers with read access can force Jenkins to send GET requests to arbitrary URLs, potentially accessing internal resources.

- **Severity:** Medium 6.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-53wf-vqf9-cgf2

## What is CVE-2018-1000182?

CVE-2018-1000182 is a medium-severity server-side request forgery vulnerability in n/a, published on 5 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A server-side request forgery vulnerability exists in Jenkins Git Plugin 3.9.0 and older in AssemblaWeb.java, GitBlitRepositoryBrowser.java, Gitiles.java, TFS2013GitRepositoryBrowser.java, ViewGitWeb.java that allows attackers with Overall/Read access to cause Jenkins to send a GET request to a specified URL.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2018-1000182?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:git. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:git` | Maven | All versions | 3.9.1 |
| `org.jenkins-ci.plugins:git` | Maven | All versions | 3.9.1 |

Products: Jenkins Git.

## How do I fix CVE-2018-1000182?

Upgrade org.jenkins-ci.plugins:git to 3.9.1 or later.

## Is CVE-2018-1000182 being exploited?

There is no known exploitation of CVE-2018-1000182 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-36882](https://insights.sbomify.com/CVE-2022-36882/): Lack of authentication mechanism in Jenkins Git Plugin webhook (high 8.8)
- [CVE-2022-36883](https://insights.sbomify.com/CVE-2022-36883/): Lack of authentication mechanism in Jenkins Git Plugin webhook (high 7.5)
- [CVE-2022-30947](https://insights.sbomify.com/CVE-2022-30947/): Path traversal in Jenkins Git Mercurial and Repo Plugins (high 7.5)
- [CVE-2017-1000092](https://insights.sbomify.com/CVE-2017-1000092/): Cross-Site Request Forgery in Jenkins Git Plugin (high 7.5)
- [CVE-2022-38663](https://insights.sbomify.com/CVE-2022-38663/): Improper masking of credentials Jenkins in Git Plugin (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000182 and fix it if it is affected.

What it is: CVE-2018-1000182 is a medium-severity server-side request forgery vulnerability in n/a, published on 5 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000182 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:git (Maven): affected all versions; fixed in 3.9.1
- org.jenkins-ci.plugins:git (Maven): affected all versions; fixed in 3.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000182/ (Markdown: https://insights.sbomify.com/CVE-2018-1000182/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000182
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000182
- OSV: https://osv.dev/vulnerability/CVE-2018-1000182

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000182/
Summaries are generated and may contain mistakes; the official description above is the record.
