{"answers":{"affected":"2 open source packages ship an affected version, including com.coravy.hudson.plugins.github:github. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000184 in the wild and no public exploit code.","fix":"Upgrade com.coravy.hudson.plugins.github:github to 1.29.1 or later.","what":"CVE-2018-1000184 is a medium-severity server-side request forgery vulnerability in n/a, published on 5 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000184 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000184 is a medium-severity server-side request forgery vulnerability in n/a, published on 5 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000184 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.coravy.hudson.plugins.github:github (Maven): affected all versions; fixed in 1.29.1\n- com.coravy.hudson.plugins.github:github (Maven): affected all versions; fixed in 1.29.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000184/ (Markdown: https://insights.sbomify.com/CVE-2018-1000184/index.md)","id":"CVE-2018-1000184","markdown":"https://insights.sbomify.com/CVE-2018-1000184/index.md","name":"CVE-2018-1000184","record":{"aliases":["GHSA-gh85-mq87-r7v3"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins GitHub Plugin","requires_auth":"low_privilege","summary":"Attackers with read access can force Jenkins to send GET requests to arbitrary URLs via the GitHub Plugin, enabling server-side request forgery.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"github","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"A server-side request forgery vulnerability exists in Jenkins GitHub Plugin 1.29.0 and older in GitHubPluginConfig.java that allows attackers with Overall/Read access to cause Jenkins to send a GET request to a specified URL.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins GitHub Plugin server-side request forgery vulnerability exists","id":"CVE-2018-1000184","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"ssrf","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins GitHub Branch Source Plugin vulnerable to Server-Side Request Forgery","id":"CVE-2018-1000185"},"packages":[{"ecosystem":"Maven","fixed":["1.29.1"],"introduced":["0"],"last_affected":[],"package":"com.coravy.hudson.plugins.github:github","purl":null,"source":"GHSA-gh85-mq87-r7v3"},{"ecosystem":"Maven","fixed":["1.29.1"],"introduced":["0"],"last_affected":[],"package":"com.coravy.hudson.plugins.github:github","purl":"pkg:maven/com.coravy.hudson.plugins.github/github","source":"GHSA-gh85-mq87-r7v3"}],"prev":{"headline":"Jenkins GitHub Plugin exposure of sensitive information vulnerability exists","id":"CVE-2018-1000183"},"products":["n/a"],"published":"2018-06-05","related":[{"cvss_score":9,"headline":"Jenkins GitHub Plugin has an XSS vulnerability","id":"CVE-2026-42523","kev_date_added":null,"published":"2026-04-29"},{"cvss_score":8.8,"headline":"CSRF vulnerability and missing permission checks in GitHub Plugin allowed capturing credentials","id":"CVE-2018-1000600","kev_date_added":null,"published":"2018-06-26"},{"cvss_score":6.5,"headline":"Jenkins GitHub Plugin exposure of sensitive information vulnerability exists","id":"CVE-2018-1000183","kev_date_added":null,"published":"2018-06-05"},{"cvss_score":5.4,"headline":"Stored XSS vulnerability in Jenkins GitHub Plugin","id":"CVE-2023-46650","kev_date_added":null,"published":"2023-10-25"},{"cvss_score":5.3,"headline":"Jenkins GitHub plugin uses weak webhook signature function","id":"CVE-2022-36885","kev_date_added":null,"published":"2022-07-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers with read access can force Jenkins to send GET requests to arbitrary URLs via the GitHub Plugin, enabling server-side request forgery.","url":"https://insights.sbomify.com/CVE-2018-1000184/"}