# CVE-2018-1000184: Jenkins GitHub Plugin server-side request forgery vulnerability exists

> Attackers with read access can force Jenkins to send GET requests to arbitrary URLs via the GitHub Plugin, enabling server-side request forgery.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-gh85-mq87-r7v3

## What is CVE-2018-1000184?

CVE-2018-1000184 is a medium-severity server-side request forgery vulnerability in n/a, published on 5 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A server-side request forgery vulnerability exists in Jenkins GitHub Plugin 1.29.0 and older in GitHubPluginConfig.java that allows attackers with Overall/Read access to cause Jenkins to send a GET request to a specified URL.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2018-1000184?

2 open source packages ship an affected version, including com.coravy.hudson.plugins.github:github. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.coravy.hudson.plugins.github:github` | Maven | All versions | 1.29.1 |
| `com.coravy.hudson.plugins.github:github` | Maven | All versions | 1.29.1 |

Products: Jenkins Github.

## How do I fix CVE-2018-1000184?

Upgrade com.coravy.hudson.plugins.github:github to 1.29.1 or later.

## Is CVE-2018-1000184 being exploited?

There is no known exploitation of CVE-2018-1000184 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-42523](https://insights.sbomify.com/CVE-2026-42523/): Jenkins GitHub Plugin has an XSS vulnerability (critical 9.0)
- [CVE-2018-1000600](https://insights.sbomify.com/CVE-2018-1000600/): CSRF vulnerability and missing permission checks in GitHub Plugin allowed capturing credentials (high 8.8)
- [CVE-2018-1000183](https://insights.sbomify.com/CVE-2018-1000183/): Jenkins GitHub Plugin exposure of sensitive information vulnerability exists (medium 6.5)
- [CVE-2023-46650](https://insights.sbomify.com/CVE-2023-46650/): Stored XSS vulnerability in Jenkins GitHub Plugin (medium 5.4)
- [CVE-2022-36885](https://insights.sbomify.com/CVE-2022-36885/): Jenkins GitHub plugin uses weak webhook signature function (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000184 and fix it if it is affected.

What it is: CVE-2018-1000184 is a medium-severity server-side request forgery vulnerability in n/a, published on 5 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000184 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.coravy.hudson.plugins.github:github (Maven): affected all versions; fixed in 1.29.1
- com.coravy.hudson.plugins.github:github (Maven): affected all versions; fixed in 1.29.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000184/ (Markdown: https://insights.sbomify.com/CVE-2018-1000184/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000184
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000184
- OSV: https://osv.dev/vulnerability/CVE-2018-1000184

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000184/
Summaries are generated and may contain mistakes; the official description above is the record.
