{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:cas-plugin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000188 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:cas-plugin to 1.4.2 or later.","what":"CVE-2018-1000188 is a medium-severity server-side request forgery vulnerability in n/a, published on 5 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000188 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000188 is a medium-severity server-side request forgery vulnerability in n/a, published on 5 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000188 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:cas-plugin (Maven): affected all versions; fixed in 1.4.2\n- org.jenkins-ci.plugins:cas-plugin (Maven): affected all versions; fixed in 1.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000188/ (Markdown: https://insights.sbomify.com/CVE-2018-1000188/index.md)","id":"CVE-2018-1000188","markdown":"https://insights.sbomify.com/CVE-2018-1000188/index.md","name":"CVE-2018-1000188","record":{"aliases":["GHSA-f8r7-7hv9-7f43"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins CAS Plugin","requires_auth":"low_privilege","summary":"Attackers with read access can force Jenkins to send GET requests to arbitrary URLs, potentially accessing internal resources.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"cas","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"A server-side request forgery vulnerability exists in Jenkins CAS Plugin 1.4.1 and older in CasSecurityRealm.java that allows attackers with Overall/Read access to cause Jenkins to send a GET request to a specified URL.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins CAS Plugin Server-Side Request Forgery vulnerability","id":"CVE-2018-1000188","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"ssrf","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"CSRF vulnerability and missing permission checks in Jenkins AbsInt Astrée Plugin","id":"CVE-2018-1000189"},"packages":[{"ecosystem":"Maven","fixed":["1.4.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:cas-plugin","purl":null,"source":"GHSA-f8r7-7hv9-7f43"},{"ecosystem":"Maven","fixed":["1.4.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:cas-plugin","purl":"pkg:maven/org.jenkins-ci.plugins/cas-plugin","source":"GHSA-f8r7-7hv9-7f43"}],"prev":{"headline":"Exposure of Sensitive Information in Jenkins Kubernetes Plugin","id":"CVE-2018-1000187"},"products":["n/a"],"published":"2018-06-05","related":[{"cvss_score":8.8,"headline":"Jenkins CAS Plugin Session Fixation vulnerability","id":"CVE-2023-32997","kev_date_added":null,"published":"2023-05-16"},{"cvss_score":6.1,"headline":"Open redirect vulnerability in Jenkins CAS Plugin","id":"CVE-2021-21673","kev_date_added":null,"published":"2021-06-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers with read access can force Jenkins to send GET requests to arbitrary URLs, potentially accessing internal resources.","url":"https://insights.sbomify.com/CVE-2018-1000188/"}