# CVE-2018-1000188: Jenkins CAS Plugin Server-Side Request Forgery vulnerability

> Attackers with read access can force Jenkins to send GET requests to arbitrary URLs, potentially accessing internal resources.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jun 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-f8r7-7hv9-7f43

## What is CVE-2018-1000188?

CVE-2018-1000188 is a medium-severity server-side request forgery vulnerability in n/a, published on 5 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A server-side request forgery vulnerability exists in Jenkins CAS Plugin 1.4.1 and older in CasSecurityRealm.java that allows attackers with Overall/Read access to cause Jenkins to send a GET request to a specified URL.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2018-1000188?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:cas-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:cas-plugin` | Maven | All versions | 1.4.2 |
| `org.jenkins-ci.plugins:cas-plugin` | Maven | All versions | 1.4.2 |

Products: Jenkins Cas.

## How do I fix CVE-2018-1000188?

Upgrade org.jenkins-ci.plugins:cas-plugin to 1.4.2 or later.

## Is CVE-2018-1000188 being exploited?

There is no known exploitation of CVE-2018-1000188 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-32997](https://insights.sbomify.com/CVE-2023-32997/): Jenkins CAS Plugin Session Fixation vulnerability (high 8.8)
- [CVE-2021-21673](https://insights.sbomify.com/CVE-2021-21673/): Open redirect vulnerability in Jenkins CAS Plugin (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000188 and fix it if it is affected.

What it is: CVE-2018-1000188 is a medium-severity server-side request forgery vulnerability in n/a, published on 5 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000188 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:cas-plugin (Maven): affected all versions; fixed in 1.4.2
- org.jenkins-ci.plugins:cas-plugin (Maven): affected all versions; fixed in 1.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000188/ (Markdown: https://insights.sbomify.com/CVE-2018-1000188/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000188
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000188
- OSV: https://osv.dev/vulnerability/CVE-2018-1000188

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000188/
Summaries are generated and may contain mistakes; the official description above is the record.
